WordPress.org

Ready to get started?Download WordPress

Forums

Editing of posts has stopped working (8 posts)

  1. PetriWessman
    Member
    Posted 9 years ago #

    I'm running a CVS copy of WordPress. Sometime during the last couple of weeks, it seems that editing of old posts has stopped working. I can go to the edit screen and edit what I want, but it's not updated -- if I view the post I get the old version. My Apache logs show a successful POST to wp-admin/post.php... looks like WordPress simply isn't storing the changes in the database for some reason.

    Anybody else have this, or is this some local weirdness? Annoying, wherever it came from :/

  2. PetriWessman
    Member
    Posted 9 years ago #

    Some additional info (in case it matters): the system is (Debian) Linux, and the WordPress version I noticed this on is a CVS snapshot updated today, 15th of January.

    I also tested with Draft posts, same effect: when I press Save the changes don't get saved, if I press "Save and continue editing" the post reverts at once to the original version.

  3. rhetoric
    Member
    Posted 9 years ago #

    I'm having the same problem using the same build (1/15/2005). Edits don't get saved, and I can't change the status of a post from "draft" to "published" or vise-versa.

  4. symantix
    Member
    Posted 9 years ago #

    I'm having the same problem. My WP is the Jan. 13th nightly.

  5. symantix
    Member
    Posted 9 years ago #

    I think I solved the problem.

    I don't know what's causing it, but if you'll replace the file called "post.php" in the wp-admin folder with the same file from the Dec.24 nightly snapshot, editing should work again.

    Let me know if you get the same results as me.

  6. motoed
    Member
    Posted 9 years ago #

    I had a "similar" weirdness with my Pages (and posts?)

    If I add a new page, set it to no comments or pings and set published status and a page order then click "create page" Everything seems fine, but if I go back in to edit the page, Allow Comments and Pings is checked and the page order is set to 0.

    If I "re-edit" those fields and click save changes, it will keep those settings. But I HAVE to do it for every post for that change to take effect.

  7. motoed
    Member
    Posted 9 years ago #

    I'm still having this exact problem and I've updated to the newest nightly to see if it was possibly corrected. Any word on this specifc problem? Is there a place other then here to report bugs like this?

    (nightly build 1-23 of beta 1.5)

  8. NuclearMoose
    Member
    Posted 9 years ago #

    Bugs can be posted at mosquito.wordpress.org. Please ensure that you search through the database there FIRST so you don't duplicate something that has already been posted. Provide as much information as possible, including any steps required to duplicate the bug.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.