WordPress.org

Ready to get started?Download WordPress

Forums

Editing Downloaded Themes (24 posts)

  1. cgheaven
    Member
    Posted 7 years ago #

    Hey people

    I recently registered cgheaven.net and im trying to link it to my forum cgheaven.net/forum. Anyway my problem is that I have downloaded a theme and in the top right hand corener of my site is says "about" I tried looking though all the css scripts for header and index and all that stuff and i found no words or anything containing "about" so I dont know how I can edit the word and change its link to cgheaven.net/forum. Help would be greatly appreciated.

    ,Nathan

  2. Samuel B
    moderator
    Posted 7 years ago #

    admin -> Manage - > Pages
    There should be an "about" page listed. Edit it's title or delete it or whatever. It's link is for page id=2.

  3. cgheaven
    Member
    Posted 7 years ago #

    Thankyou very much.

  4. cgheaven
    Member
    Posted 7 years ago #

    Sorry to bother you again but how can i change the link value?

  5. moshu
    Member
    Posted 7 years ago #

    Which link? And what do you mean by "value"?

  6. cgheaven
    Member
    Posted 7 years ago #

    Well i changed the about button to forum. But when i click the forum button it sends me to cgheaven.net/page_id=7

    I want it to send me to cgheaven.net/forum

    Understand?

  7. moshu
    Member
    Posted 7 years ago #

  8. cgheaven
    Member
    Posted 7 years ago #

    That link doesn't really help me as I don't know where to change the link.

  9. moshu
    Member
    Posted 7 years ago #

    And I don't know what the original code was there that you tried to change.

  10. cgheaven
    Member
    Posted 7 years ago #

    I tried changing the word forum to a hyperlink but it just show the hyperlink and still sends me to cgheaven.net/?page_id=7

  11. moshu
    Member
    Posted 7 years ago #

    That's why I gave you the link to the school. To learn where do you put the link text and where the URL.
    <a href="http;//this-is-the-URL.com">thisisthelinktext</a>

    Instead of posting again and again about the same you should start to do some homework...

  12. cgheaven
    Member
    Posted 7 years ago #

    I told you I just tried that. How bout going to http://www.cgheaven.net and look in the top right hand coroner. Look what happens!

  13. moshu
    Member
    Posted 7 years ago #

    If you are messing around with the wp_pages_list template tag - that's a different story.

  14. cgheaven
    Member
    Posted 7 years ago #

    Im not messing around with that. I can edit the page template just tell me what section of text I have to change. Can you please tell me what I have to change to edit the link from

    http://cgheaven.net/?page_id=10

    to
    http://cgheaven.net/forum

  15. cgheaven
    Member
    Posted 7 years ago #

    How hard can it be....? I know it must be simple. Please help.

  16. PeterTountas
    Member
    Posted 7 years ago #

    I have run across the same problem and have tried everything possible to get rid of the "About" and the sentence that follows. Nothing seems to work.
    Any more ideas anyone?

  17. Joni
    Member
    Posted 7 years ago #

    Nevermind.

  18. pwtgirl
    Member
    Posted 7 years ago #

    PeterTountas --
    To get rid of the word About and the sentence that goes with it open sidebar.php and remove or change the below on about line #65:

    <div class="sidelist">
    <h2>About</h2>
    <p>You can post a brief statement here that tells people what your site is about. Or not.</p></div>

  19. pwtgirl
    Member
    Posted 7 years ago #

    Darn gotta figure out how to post in the forum so it doesn't apply the code and just shows it. Back in a moment to repost. Still can't get the code to show so I placed in in a pastebin post for you..

    cgheaven --

    You have already been given more than enough help to fix this issue. But since it seems you aren't paying attention to those helping you here is a quick fix.

    In header.php of your theme you see the below lines of code:

    </style>
    </head>
    <body>
    <div id="pages">
    <h1>"><?php bloginfo('name'); ?></h1>

      <?php wp_list_pages('depth=1&title_li=' ); ?>

    </div>

    This part <?php wp_list_pages('depth=1&title_li=' ); ?> right there is what is making the page title links show up in the right hand side of the top of your site.

    "About" is one of the pages you have in your site. Simply changing the link name will only change the text shown for the link. It will still link to the page created in wordpress that was originally named "About"

    The only way I can think of to remove the wordpress page listings in that spot and add only a link to your forum would be to change the code bit in header.php

    You could remove the <?php wp_list_pages('depth=1&title_li=' ); ?> part all together which will remove the links to the wordpress pages in your site. Not sure if that is what you want to do or not but any how read on..

    So if you were to say replace the above section of code I showed you at the top of this reply with the code in this link http://wordpress.pastebin.ca/294215 then it will get rid of all your wordpress page links in that section and give you only the link to your forum.

    If you do remove the <?php wp_list_pages('depth=1&title_li=' ); ?> tag from the header as shown above I would think about putting it in the sidebar maybe. That way your visitors will still be able to find your wordpress pages.

    -- Mindy

  20. cgheaven
    Member
    Posted 7 years ago #

    Mindy I have already fixed it with a much easier method (which I discovered myself) Thanks for the post anyway.
    ADMIN>OPTIONS>PERMALINKS, Custom,specify below change to
    /http:/cgheaven.net/forum

    Easy, but you can only have one link. Its bad if you want more than one links.

  21. pwtgirl
    Member
    Posted 7 years ago #

    cgheaven --

    That fix won't actually work for you though. Yes it did fix the link for the forum in the top right of your site but have a look at any of the other links in your posts etc.. They are all messed up now. For instance click on one of the post titles or comments for a post you'll see what I mean.

  22. moshu
    Member
    Posted 7 years ago #

    Keep the wp_pages_list and use the Redirectify plugin.
    http://redalt.com/Resources/Plugins/Redirectify

  23. cgheaven
    Member
    Posted 7 years ago #

    I downloaded Redirectify plugin but does anyone actually know how to use it? There are no settings in the administrate panel....

  24. cgheaven
    Member
    Posted 7 years ago #

    Don't worry, I found this thread very helpful!

    http://wordpress.org/support/topic/58817?replies=7

Topic Closed

This topic has been closed to new replies.

About this Topic