WordPress.org

Ready to get started?Download WordPress

Forums

edited theme names massively long (7 posts)

  1. marinegirl
    Member
    Posted 8 years ago #

    Sorry, this must be really simple, but I can't find the answer anywhere.

    Whenever I have edited a theme, or created a new one from scratch, on the list of current / available themes instead of just displaying the theme title, it looks as though its displaying the entire file...

    For example, I have installed the K2 theme, and changed bits of it. I now call it K2 underwater, to avoid confuison with the original. This is whats displayed...

    Current theme:
    K2underwater Theme URI: http://binarybonsai.com/wordpress/k2/ Description: K2 for marinegirl Author: Michael Heilemann & Chris J Davis & me Author URI: http://binarybonsai.com/ /*- Page Structure */ body { font: 62.5% 'Lucida Grande', Verdana, Arial, Sans-Serif; /* Resets 1em to 10px */ color: #444; background-color:#666666; text-align: center; margin: 0 0 30px; } #side { background: white; width:250px; } #page { text-align: left; margin: 0 auto; padding: 0px 0 0px; position: relative; /* The entire template's width is set in this class. */ width: 600px; } #header { width: 600px; margin: 10px auto; position: relative; height: 200px; } #top { width: 600px; padding: 0; margin: 10px auto; position: relative; height: 30px; background: url('images/topbg.png'); } .primary { width: 580px; float: right; padding: 10px; margin: 0 0px 0 0px; _margin: 0 20px 0 15px; /* IE Hack */ display: inline; background-color:#ffffff; } .secondary { font: 1em/1.5em 'Lucida Grande', Verdana, Arial, Sans-Serif; padding: 10px 0; margin: 0 0 20px 0; float:left; background-color:#FFFFFF; width: 250px; color: #666; position: relative; /* The following are IE Fixes */ _padding: 30px 0 10px; _margin-left: 0%; _margin-right: -4%; _width: 26.5%; } .comments { text-align: left; padding: 30px 0 0; position: relative; } /*- Main Menu in Header */ #top a { font: 1em Verdana, Helvetica, Arial, Sans-Serif; color:#666666; margin: 0; } #top a:hover { color:#000000; text-decoration: none; } ul.menu { margin: 0; paddi......

    and on and on.

    Not only is it really irritating, but I cant use a theme-switcher beacause all of that shows up on the list, and it cant be clicked because the generated url is too long!

    Please help!

    Thanks,

    Becks

  2. Ajay
    Member
    Posted 8 years ago #

    This could be because the entire style.css file has landed up on a single line as opposed to multiple lines.

    Check out style.css in a good editor like Notepad++ or similar

  3. chuck232
    Member
    Posted 8 years ago #

    Did you comment out the first lines of theme info properly? Perhaps you didn't close the comment or something and the whole stylesheet is becoming the name.

  4. marinegirl
    Member
    Posted 8 years ago #

    I've been editing in dreamweaver, but I checked in text edit and seems to all be on different lines.
    I think I've commented out properly... I mean I've only changed bits rather than re-writing. It looks likt this:

    /*
    Theme Name: K2underwater
    Theme URI: http://binarybonsai.com/wordpress/k2/
    Description: K2 for marinegirl
    Author: Michael Heilemann & Chris J Davis & me
    Author URI: http://binarybonsai.com/
    /*
    /*- Page Structure */

    body {
    font:.......

    How confusing :(

  5. iand
    Member
    Posted 8 years ago #

    What program are you editing with? This sometimes happens if the 'line endings' are not set right. I think they should be set to 'unix' if you have that option.

    See:
    http://wordpress.org/support/topic/38242 and
    http://wordpress.org/support/topic/27916

  6. eridan
    Member
    Posted 8 years ago #

    You should end comments with */. In other words, you've closed the comment incorrectly

  7. marinegirl
    Member
    Posted 8 years ago #

    Line endings was it :) Thanks everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.