Ready to get started?Download WordPress


"Edit Your Submission" appears as a plain text excerpt (4 posts)

  1. christopher.i
    Posted 3 years ago #

    We are running WordPress 3.0.1 and the only plug-ins we are using are Cincopa and uCan Post which I do not believe to be creating this bug, but I am not completely sure.

    When a user creates a new post without an excerpt, the excerpt text always ends with a plain text line reading "Edit Your Submission"

    I just can't figure it out. These two screenshots below should make the problem clear. Any ideas?



  2. Bill Erickson
    Posted 3 years ago #

    My guess is that somewhere in a theme or plugin is a function that's modifying the excerpt "Read More" text. See: http://codex.wordpress.org/Plugin_API/Filter_Reference/excerpt_more

    First, disable each plugin individually and see if it goes away - that will identify if it's caused by a plugin. If nothing happens after they've both been disabled it's probably in your theme. To confirm you can switch to the default theme, 2010.

    If it's in the theme, look in the functions.php file for something that says add_filter('excerpt_more', ...

    If you either remove or comment this line out it should fix it. Make sure you are making these changes using an FTP editor or something other than the editor in the backend of WordPress. If you do something wrong and create an error, you won't be able to log back into WordPress to fix it.

  3. fccpuyallup
    Posted 3 years ago #

    I'm having the same problem, and interestingly, I use uCan Post. Any updates on this issue?

  4. christopher.i
    Posted 3 years ago #

    Well, I do know the problem is coming from uCan Post, but I am unsure how to fix it. We decided since only admins can sign in, and the error doesn't appear to guests, that we would move on without fixing the bug. It does not seem to negatively affect user interface.

Topic Closed

This topic has been closed to new replies.

About this Topic