WordPress.org

Ready to get started?Download WordPress

Forums

Edit Timestamps appears not to work (11 posts)

  1. jonmccullochcom
    Member
    Posted 7 years ago #

    Hi all,

    If I create a post and use the Edit Timestamp function to make it appear in the future, something curious is happening.

    In the Admin panel the time until the post is due to be published counts down... but when the appointed minute arrives, the post not only doesn't appear, but the time starts counting up again.

    For example, if I set a post to be displayed at 16:30 and create it at 16:27, it counts down 3, 2, 1... but then at 16:32 the count shows 2 again, and the post doesn't appear.

    I've use Save and Publish, but the same thing happens with both. I'm in the UK so I'm currently running my software on UTC. And yes, I'm making sure the Edit Timestamp checkbox is checked.

    I'm flummoxed, I tell you.

    Could this be a theme-thang? Any other ideas?

    --

    Jon

  2. jimmycanuck
    Member
    Posted 7 years ago #

    I am having the same problems. If anyone out there has any solution, it would be greatly appreciated. :)

  3. drmike
    Member
    Posted 7 years ago #

    Are you checking the box within that tab? I know the first poster says that they're are but I just wanted to make sure.

    When I see this issue, it's usually a time zone issue. I'd wait 24 hours and see when, if ever the post does show up.

  4. jimmycanuck
    Member
    Posted 7 years ago #

    Yes, I'm checking the tab. Unfortunately my problem is exactly like the first poster -- it'll count down to post time and then when it reaches zero and should go live the timer starts counting up and the post stays stuck unless I go in and publish it again. :(

  5. jimmycanuck
    Member
    Posted 7 years ago #

    Does nobody have a fix for this? I can find a number of threads posing the same problem, but none seem to offer a solution or a workaround. Futureposting is a fantastic feature, and I'd love to get it working.

  6. yoshi
    Member
    Posted 7 years ago #

    As everything working fine for me I'm not sure about this problem at all, but can you try this for me?

    open your wp-config.php,
    and just above require_once(ABSPATH.'wp-settings.php');,
    add this line:
    define('DB_PASS', DB_PASSWORD);

    Then access your dashboard.

  7. jimmycanuck
    Member
    Posted 7 years ago #

    Thank yoshi - I'll try that shortly (as soon as I'm back on my home computer). What should happen when I go to the dashboard?

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    yoshi: I see where you're going with that, but it's not the problem. Note the call from spawn_cron in cron.php. It's just a reference. Supposed to be unique, but not in this case. This is actually fixed rather nicely in SVN, BTW.

    Anyway, the only reason I can think that it doesn't work is that wp-cron is never getting run by the server at all. Unfortunately, there could be a lot of reasons for that. It's hard to know where to start looking.

  9. yoshi
    Member
    Posted 7 years ago #

    Otto, yeah you're right. That wan't the point. And thanks for the info on fix in SVN. That's nice to know that.

    the only reason I can think that it doesn't work is that wp-cron is never getting run by the server at all.

    If that's the case, would this be a temporary solution?

  10. jimmycanuck
    Member
    Posted 7 years ago #

    Sorry I haven't had a chance to respond lately. Busy week. yoshi - I'm not sure what I'd do with the link you provided. I'm rather noobish. Sorry. :(

    If anyone knows what the issue is and how to resolve it, I'd be forever in your debt. I desperately want to get future posting to work.

  11. mrsdeane
    Member
    Posted 6 years ago #

    I have the same problem as the OP and posted about this is in a new thread. No answer there, no answer here. Isn't there anybody who knows what is causing this, not even from the WP team itself?

Topic Closed

This topic has been closed to new replies.

About this Topic