WordPress.org

Ready to get started?Download WordPress

Forums

Spots
Edit Spot (10 posts)

  1. believerinsight
    Member
    Posted 1 year ago #

    Using Widget, link appears "edit spot". This appears for both those logged in and those not.

    Is there a way to remove this link.

    http://wordpress.org/extend/plugins/spots/

  2. ilanfl
    Member
    Posted 1 year ago #

    Happening to me too.

    Seeing that the only relevant result on Google is your question, from 5 hours ago, I think it might be a new bug.

    I also just installed this plugin so I'm not sure.

  3. Steve Borsch
    Member
    Posted 1 year ago #

    I rely on Spots so much that, IMHO, I think that widget WYSIWYG should be part of WP core.

    Experiencing the same thing as you are, believerinsight and ilanfl, but wondering if either of you are running a caching plugin? I ask since I'm running W3TC and, though it is set to NOT cache admin pages, I just noticed that a critical homepage Spot I added above my slider (900px by 200px) had a HUGE "Edit Spot" that appeared for non-loggedin users!

    This is very bad.

    Suggestion for Immediate Fix: Spots need to have a DONOTCACHE applied to them.

  4. ilanfl
    Member
    Posted 1 year ago #

    Hey Steve.

    I don't have any caching plugins on wordpress, but I MIGHT have cache as part of my webhost services, I'm having a little trouble figuring out if I do

    Makes sense that is the cache.

  5. Su
    Member
    Posted 1 year ago #

    Also seeing edit links for non-authd users. Using the shortcode in my case.

    EDIT
    The problem has something to do with Spots' caching feature, at line 1258 of icit-spots.php. If you set the Spots cache time to 0(disabled), the edit links are no longer erroneously presented. Since many/most users are probably using a dedicated caching plugin, this is probably a reasonable workaround until the Spots dev addresses.

  6. Steve Borsch
    Member
    Posted 1 year ago #

    Thanks Su. Just opened icit-spots.php and it *is* set to 0 so I'll have to wait until the Spots dev fixes it.

  7. Steve Borsch
    Member
    Posted 1 year ago #

    Doh...just saw the update included a fix so we're all set!

  8. Steve Borsch
    Member
    Posted 1 year ago #

    The 1.1.7 update did NOT fix this issue. Also, where exactly does the "0" value go in this string below?

    function cache_time_field() {
    			echo '<input type="text" name="spots_cache_time" value="' . get_option( 'spots_cache_time', SPOTS_CACHE_TIME ) . '" />';
    			echo '<p class="description">' . __( 'Enter an amount of time in seconds to cache spots for. Set to 0 to turn the caching off, recommeneded if you use a caching plugin.' ) . '</p>';
    		}
  9. Su
    Member
    Posted 1 year ago #

    My comment might've been unclear.
    You're not hacking the source; I was just including where it seemed the problem was.

    There's a setting within the UI for the cache time. Set that to "0".

  10. AndyiBM
    Member
    Posted 1 year ago #

    Strange - I'm NOT getting this issue (I'm on latest WP and Spots versions), although I have a client who did have this issue, but he now says after upgrading to 1.1.7 the issue is sorted.

    We do, however, both have this issue: http://wordpress.org/support/topic/spots-widget-doesnt-display-spot-details?replies=2 which no-one else seems to have (no other comments on it).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags