WordPress.org

Ready to get started?Download WordPress

Forums

3.0-alpha - Edit Site > Update Options > Error 400: Bad Request (20 posts)

  1. DanVet
    Member
    Posted 4 years ago #

    I have WP3 alpha installed and working nicely except one thing: when I try and edit the site settings (/wp-admin/ms-sites.php?action=editblog&id=2) I get a 400 Error whenever I press the "Update Options" Button.

    I notice that the page that gives the 400 Error is "wp-admin/ms-edit.php?action=updateblog" there is no "&id=2" on the end. If I add "&id=2" to the address and resubmit, I get a page with a box containing the text "Are you sure you want to do this?" - but there are no buttons to go on from there.

    Any suggestions as to why I'm getting this error?

  2. DanVet
    Member
    Posted 4 years ago #

    Still can't get this to work. Anybody have any suggestions at all? I'm guessing it is a server problem or maybe something in the .htaccess file...

  3. Are you running out of a sub directory?

    What's in your .htaccess?

    Is this happening on all blogs or just one?

    I reproduced this ONCE but then it magically vanished yesterday. I have no idea what happened :/

  4. DanVet
    Member
    Posted 4 years ago #

    Hey! Thanks for the reply.

    Yes - i am running out of a sub directory. The main install is in a sub directory and the individual blogs are in sub-directories (rather than canonical domain names).

    My .htaccess is as follows:

    RewriteEngine On
    RewriteBase /wpbeta/
    
    #block .htaccess viewing
    RewriteRule ^\.htaccess$ - [F]
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    And, yeah - it's happening in all blogs... :(

  5. FWIW, I have a similar setup. I have the install in /public_html/wp but it runs out of domain.com (and not domain.com/wp) with blogs running out of subfolders (domain.com/wp/blog2 and domain.com/wp/blog3 etc). That has it's own weirdness with a couple things (like the signup page ran to an endless loop...), but it's working now, so I know it CAN work.

    I'm assuming the .htaccess file is in your /wpbeta folder and not your /public_html folder.

    What happens if you take out the block .htaccess viewing bit?

  6. DanVet
    Member
    Posted 4 years ago #

    What happens if you take out the block .htaccess viewing bit?

    No change. I'll try an install in the root directory.

    On a side note, I love the look, feel and organization of your site. What I'm trying to achieve with multiple blogs is 1) a personal blog, 2) a photo blog and 3) a work-related blog. I wondered for a short while if I shouldn't just use categories to achieve this - but I think I'll stick to my original game plan.

    Thanks again for your reply.

  7. Oh lord, which site? ;) ipstenu.org is just me, fartin around. jorjafox.net is running WP 3-alpha, and that's where I'm getting this.

    I really have an aversion to running WP out of root (it's so unorganized).

    Did you convert from WP Single to WP Multi? I'm wondering if your SQL db isn't missing a reference... I'm off to look at mine.

  8. DanVet
    Member
    Posted 4 years ago #

    Did you convert from WP Single to WP Multi?

    Yes - I thought this was the only way to install. I did the standard install and then immediately made the required changes to convert to multi-site. Can you force a multi-site install from the get-go?

    I'm wondering if your SQL db isn't missing a reference... I'm off to look at mine.

    It was a clean database at the start of the install.

    I just wasted the last couple of hours playing with the latest nightly build - apparently the installer is broken on this build. (Didn't work for me anyway). I'm now in the process of installing the nightly build from a couple of days ago (which I know, at least, installs) into my root directory.

  9. DanVet
    Member
    Posted 4 years ago #

    Made no difference installing in the root... :(

    Now trying to update to the latest nightly build.

  10. DanVet
    Member
    Posted 4 years ago #

    No luck. The same thing happens with the latest WP Mu build too - which makes me think it's a server roblem rather than a WP problem. I just don't know where else to look!

  11. I took a 2.9 and upgraded to 3.0 before flipping to MS and it worked, but really that shouldn't matter at all, right?

    Sorry, I'm tapped :(

  12. DanVet
    Member
    Posted 4 years ago #

    Resolved - needed to get my web host (JodoHost) to add mod_security exclusion rules.

    Thanks for your help, Ipstenu!

  13. AHA! ModSec, the most usefully insidious part of a server :)

  14. Andrew
    Member
    Posted 4 years ago #

    Dumb questions and off topic, but where can I get the alpha wp3.0?

  15. It's a trunk build right now.

    http://core.trac.wordpress.org/browser/trunk and scroll to the bottom to download the zip.

    DO NOT do this unless you are totally copacetic with possibly blowing up your site. It's a DEV version, and not made for prime time. :)

  16. Andrew
    Member
    Posted 4 years ago #

    I will be running it in my test directory. Well, I am not a prime time guy, but I love seeing what the developers are doing.

    Thanks for the heads up!!!

    Andrew

  17. vteixeira
    Member
    Posted 4 years ago #

    You should report this problem on TRAC.

    trac.wordpress.org

  18. It's not a trac issue. It's a server setup issue. Some servers just get picky about mod_security and there's nothing WP can do about it.

  19. p01acos
    Member
    Posted 3 years ago #

    I found a solution, for my case at least
    It was the pernamentlink problem. When I created a new post with a title with some special characters like Apple's or Day's, server could not find the post because of this sign. Solutions is to keep your pernamentlink settings as you want, delete permanently (before copy it to a word or notepad) and create a new post, with title without any special characters. Please comment if worked.

  20. p01acos
    Member
    Posted 3 years ago #

    But if you already changed the permanentlinks, you will have to do it to every single post.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.