WordPress.org

Ready to get started?Download WordPress

Forums

edit problem with 2.6 (21 posts)

  1. frpeneaud
    Member
    Posted 6 years ago #

    I can't edit some of my posts with wp 2.6.
    I get this message when I try to use the edit page:

    -----
    Warning: main(Text/Diff/Renderer.php) [function.main]: failed to open stream: No such file or directory in [path to my site]/wp-includes/Text/Diff/Renderer/inline.php on line 17

    Fatal error: main() [function.require]: Failed opening required 'Text/Diff/Renderer.php' (include_path=[path to my site]/include:.:/usr/php4/lib/php') in [path to my site]wp-includes/Text/Diff/Renderer/inline.php on line 17
    -----

    It seems to happen only when I've added an image to the post via the media uploader. I haven't modified any of the wp files, and it didn't happen with 2.5. I've done the upgrade by the book, but maybe I've done something wrong?
    Thanks for any help you can give me.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    You failed to upload all of the WordPress files.

    Reupload. Especially the wp-includes directory.

  3. Walien
    Member
    Posted 6 years ago #

    Hi,
    I've the same problem as frpeneaud and a re-upload of all the WP 2.6 files didn't change anything. We are some french users with this problem. (I try to ask here if a solution is found before the french board ^^).

    Edit : Strange thing, I can edit a Page, but not a post...

  4. frpeneaud
    Member
    Posted 6 years ago #

    Otto, thanks for your answer, but re-uploading doesn't seem to work.
    Any other idea?

    Walien, is your site on free.fr?
    I'm asking because I know there has been some specific problems with wp on free.fr.

  5. Walien
    Member
    Posted 6 years ago #

    Yes I'm on Free.fr (Baaaaad ^^).

  6. Walien
    Member
    Posted 6 years ago #

    Strange thing (again ^^). The blog I was working on is a new blog. So there was only one post. I've deleted it and now I can edit the others.

  7. frpeneaud
    Member
    Posted 6 years ago #

    I can always edit the others, but not the one where I've put the image, even when I go to the mysql db and delete the image coding.

    So, anyone else can help us?

  8. frpeneaud
    Member
    Posted 6 years ago #

    Bump.
    Nobody can help us?

  9. Anonymous
    Unregistered
    Posted 6 years ago #

    I have exactly the same problem. I can edit some posts, but othe rpost give me: Warning: require(Text/Diff.php) [function.require]: failed to open stream: No such file or directory in /domains/xxxx.xxxx.dk/www/wp-includes/wp-diff.php on line 4

    Some of the post I cant edit does contain images and some don't.

    I really would love som response from WordPress :-)

  10. hotkee
    Member
    Posted 6 years ago #

    As Otto42 said, you are missing files - you need to check each and every folder to see whats in them or do a clean fresh upload.

  11. Anonymous
    Unregistered
    Posted 6 years ago #

    Sorry - I just found out! My upload changed from capitalized to lower case - e.g. "Diff.php" was renamed to "diff.php".

    Changing every letter back to the original - and everything works! Maybe this might help others.

  12. clsfrr
    Member
    Posted 6 years ago #

    i cant edit either...

    please rosenstand could you specify what files and dirs have to be changed?...
    thx

  13. Anonymous
    Unregistered
    Posted 6 years ago #

    It worked for me, I had to check all files in the wp-includes / text folder, these included the following:

    Folder
    wp-includes / text
    Changed to: wp-includes / Text

    File
    wp-includes / Text / diff.php
    Changed to: wp-includes / Text / Diff.php

    Folder
    wp-includes / Text / diff /
    Changed to: wp-includes / Text / Diff /

    File
    wp-includes / Text / Diff / renderer.php
    Changed to: wp-includes / Text / Diff / Renderer.php

    Folder
    wp-includes / Text / Diff / renderer /
    Changed to: wp-includes / Text / Diff / Renderer /

    Folder
    wp-includes / Text / Diff / engine /
    Changed to: wp-includes / Text / Diff / Engine /

    After that it seems to be a ok... Hope it works for you guys too.

    Redbyte

  14. clsfrr
    Member
    Posted 6 years ago #

    Perfect Redbyte, after renaming, works properly.

    thx

  15. codestyling
    Member
    Posted 6 years ago #

    There are still hard problems remaining, if your provider has disabled the ini_set() function for security reasons. You will get a fatal error and won't be able to edit any longer. I wrote an article: http://www.code-styling.de/english/wordpress-26-and-the-textdiff-fatal-errors
    and also a patch therefore. It has been submitted at WP Bug Trac too.

  16. plutopsyche
    Member
    Posted 6 years ago #

    I sincerely hope this solution works.

    Why on Earth would they code with forced uppercase folder and file names?

    Hopefully this will be fixed in 2.6.1! Thanks!

  17. clsfrr
    Member
    Posted 6 years ago #

    now, i cant add http links in the articles ... -.-'

  18. bornfamous
    Member
    Posted 6 years ago #

    It's not fixed in 2.6.1 and the patch by codestyling doesn't work for me. I don't know what to do. My client is NOT happy.

  19. lanooz
    Member
    Posted 5 years ago #

    I have the sanem problem, since I updated blog to 2.6.1 (2.6?) how far I can remember.
    I checked those files that ^redbyte mentioned, they're properly uploaded (first, uppercase letter).
    So I think, my problem is that my hosting provider (Dreamhost.com) had disabled the ini_set() function.
    I won't ask my privder to enable this fucntion if this has been submitted to WP Bug Track already (2.7 version very soon!) So now, I prefer to just edit quickly some files: http://www.wacdesigns.com/2008/08/02/fatal-error-require_once-functionrequire-failed-opening-required-textdiffrendererphp/

  20. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    There is no "ini_set" bug anywhere in WordPress 2.6.2, because the places that ini_set is used are all ignoring the result.

    See, this message:
    ini_set() has been disabled for security reasons in /.../wp-includes/pluggable.php on line 1517
    ...doesn't make any sense, because pluggable.php does not contain any reference to "ini_set" at all.

    Now, the phpmailer class does use ini_set in some cases, however it checks for safe mode first and doesn't use it in those cases.

    Also, upper/lowercase always matters. Only Windows doesn't care, every other operating system on the planet does. So yes, case is important and always has been.

  21. xeroteam
    Member
    Posted 5 years ago #

    I was getting a similar error, however, without the "inline.php" file. I used the patch from code-styling.de, but that didn't help.

    Then for shitz and giggles, I went to one of my working blogs, copied the Test folder, pluggable, and wp-diff files over to the blog that was broken. It worked perfectly. Before copying, I erased all instances of the "bad" files and folder from the broken blog to avoid any mishaps...

    The broken blog was WP 2.6.2, the working blog was a WP 2.6.1 but the files copied over fine and without error.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.