WordPress.org

Ready to get started?Download WordPress

Forums

Edit plugins failing after 3.3.1 (2 posts)

  1. washingtonmike
    Member
    Posted 2 years ago #

    Just upgraded to 3.3.1 and now am NOT able to edit any of my plugin files. The Update button does not appear and the message instead does "You need to make this file writable before you can save your changes. See the Codex for more information."

    File permissions are currently set at 755 for wp-content, 755 for plugins, 755 for the plugin folder and 644 for the individual file.

    I've tried changing from 644 to higher (all the way to 777) for the file permission with no luck.

    help, please. Thanks. Mike

  2. Peter Wooster
    Member
    Posted 2 years ago #

    I just tried editing a plugin on my site that is running 3.3.1 and it worked as expected.

    Editing plugin code (or any other code) directly on a production site is not good practice. You should make changes like that using a programmers' editor that does code syntax colouring so you can check for syntax errors, test it locally or on a test system and then transfer it to production. If you do this you can also tighten up the access to code files so that your site is more secure.

    /peter

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.