WordPress.org

Ready to get started?Download WordPress

Forums

"Edit Permalink" option missing from "Page Edit" screen? (7 posts)

  1. Kimb Jones
    Member
    Posted 5 years ago #

    As you can see from the screenshot:

    http://i43.tinypic.com/152eq21.gif

    My "Edit Permalink" option has somehow been removed from the "Page Edit" screen?

    Site A works fine and is an upgrade of WP 2.5.

    Site B is missing the option and is an upgrade of 2.3.

    Both sites are running 2.7 and neither have plug any plugins active at the time of the screenshot.

    I've tried to re-edit the permalink structure on Site B but it did nothing.

    I also tried the 2.7 'reinstall' option under 'tools'.

    Can anyone help me get this option back?

  2. MichaelH
    Member
    Posted 5 years ago #

    I set Permalink Structure, via Administration > Settings > Permalinks, to Day and Name, and when I edit a Post (or Page) the permalink edit is displayed below the Title field.

    Any plugin causing a problem?

  3. Kimb Jones
    Member
    Posted 5 years ago #

    Yes, tried that. In fact, I modded the permalink structure to a few options, including the 4 defaults, just to see if anything would happen.

    I disabled all of my plugins and it still didn't appear. I then looked at 2 other WP 2.7 sites I run and they both have the Permalink option, this seems to be the only site effected yet I am stumped to work out how it is different as I upgraded it to 2.7 in the same way I did the other sites.

  4. Kimb Jones
    Member
    Posted 5 years ago #

    Toiled with this over the weekend, I can't seem to get it back.

    Of course its not a huge problem as I can use the "Slug" to edit the same value. I just hate niggleing little bugs like this.

    I now plan on re-installing so I will be in touch!

  5. BloggerDesign
    Member
    Posted 5 years ago #

    I have the same problem on multiple blogs and it's extremely annoying. I can't edit the page URL until after it's published. Not cool.

  6. ventrilqstman
    Inactive
    Posted 5 years ago #

    This is nuts. Where'd it go?

    I even tried un-publishing the page and the trying. Still no permalink edit. The automatic structure is no good. I build whole sites with WP and I need the control the url.

    Is the WP dev team ignoring this or what?

  7. ventrilqstman
    Inactive
    Posted 5 years ago #

    OK fixed it.

    I had permalink structure set to default and in that mode it does not allow us to change the permalink manually for some stupid reason.

    If I set up a customer permalink structure and apply it it will also allow me to manually edit the permalink.

    Hopefully they fix this bug in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags