WordPress.org

Ready to get started?Download WordPress

Forums

"Edit Image" - image does not show up... (6 posts)

  1. plot0006
    Member
    Posted 1 year ago #

    Hi.
    We have the same problem on a few of our sites.
    Then going into media and pressing on Edit Image, or uploading a new image and then pressing Edit Image - all we get is a blank spot.
    I can see the uploaded image on the right. But can't see the image I need to crop.

    Just like in this example:
    http://i42.tinypic.com/1j25nk.jpg

    I know the problem might be in functions.php with spacing, but - it works just fine on my local, and on staging( which the same as live ) but the actual live site is broken.

    We are using bones as base to our themes.

    Any help, suggestions, recommendations will be greatly appriciated.
    Thank you.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. plot0006
    Member
    Posted 1 year ago #

    Just tried it all on my local - one of those sites doesn't work on the local as well, didn't want to interfere with live site.

    - Switching to Twaty Eleven didn't help.

    - Disabled all plugins. Still nothing.

    - Followed the instruction on how to reset the Plugins folder. Still nothing.

    Then looking at the image editor in Safari I can see the broken linked image - url - http://mysite.ca/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=5f18b24e1d&postid=8827&rand=57584

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Just tried it all on my local

    No - that's not a valid test. The server environment on the live sites could be very different to your local one. And this difference (in say, a PHP version) could expose an serious error in a theme or plugin that otherwise works just fine locally.

  5. plot0006
    Member
    Posted 1 year ago #

    ok. Found that might be the problem.

    The issue seems to be with wp-jquery-lightbox
    BUT
    On one site - WordPress 3.2.1 - it breaks the image edits then on.

    On a second site - WordPress 3.4. - it breaks the image edits then on.

    On a third site - WordPress 3.3.2 - the plugin is on and the editor works fine.

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    That sounds like there's a problem with the version of jQuery that the plugin is using.

Topic Closed

This topic has been closed to new replies.

About this Topic