WordPress.org

Ready to get started?Download WordPress

Forums

Ecto Stuck Retrieving Categories (2 posts)

  1. gusleig
    Member
    Posted 7 years ago #

    I have a blog gusleig.com after I upgraded to wordpress 2.1 ecto stop working, it says "retrieving categories" forever and stucks.
    Can you help me fix this?

    Request with URL:
    http://www.gusleig.com/sos/xmlrpc.php
    and data:
    <?xml version="1.0" encoding="UTF-8"?>
    <methodCall>
    <methodName>mt.getPostCategories</methodName>
    <params>
    <param>
    <value><string>238</string></value>
    </param>
    <param>
    <value><string>admin</string></value>
    </param>
    <param>
    <value><string>******</string></value>
    </param>
    </params>
    </methodCall>

    Response:
    <?xml version="1.0"?>
    <methodResponse>
    <params>
    <param>
    <value>
    <data>
    <value><struct>
    <member><name>categoryName</name><value><string>Foto</string></value></member>
    <member><name>categoryId</name><value><int>7</int></value></member>
    <member><name>isPrimary</name><value><boolean>1</boolean></value></member>
    </struct></value>
    <value><struct>
    <member><name>categoryName</name><value><string>Downloads</string></value></member>
    <member><name>categoryId</name><value><int>12</int></value></member>
    <member><name>isPrimary</name><value><boolean>0</boolean></value></member>
    </struct></value>
    </data>
    </value>
    </param>
    </params>
    </methodResponse>

  2. foolswisdom
    Moderator
    Posted 7 years ago #

    I have created #3662: Can't post using Ecto b/c categoryID should be string not int.
    A patch is available for WordPress (core) and should be included in the first maintenance release of WordPress 2.1 . Please try it and add a comment to the ticket in trac saying you tested it.

Topic Closed

This topic has been closed to new replies.

About this Topic