WordPress.org

Ready to get started?Download WordPress

Forums

easy to set pretty permalinks after site is live? (5 posts)

  1. schoolspeak
    Member
    Posted 2 years ago #

    Right now, I'm developing a CMS website on WordPress using WAMP. My pages are now "www.site.com/page id=1", etc. I'd like them to be "www.site.com/contact", etc. Using WAMP, I can't get pretty permalinks to work. I get a "not found" error if I try to use /%postname%/ with my static pages. (Yes, I've tried the "httpd.conf" trick in WAMP, and inputting code into .htaccess)

    Question is: If I can live with ugly permalinks while I'm developing the site, will this be easy to configure once the site is live? In other words, is WAMP the only thing standing in my way when it comes to pretty permalinks working?

    Thanks in advance.

  2. ClaytonJames
    Member
    Posted 2 years ago #

  3. schoolspeak
    Member
    Posted 2 years ago #

    So it looks like as long as I can get this .htaccess file to play nice, my answer may be "yes"? Funny thing is, I have had wordpress automatically rewrite over my .htaccess file but when I save those changes, things still don't work right. (So I kept changing it back!)

    That sounds like a good sign to me. So hopefully all I need is to get this site live eventually and then do the .htaccess trick and be done.

    You'd think it would be easier to get some pretty permalink structure going. It feels like the Wild West days of WordPress design when things like this happen.

  4. ClaytonJames
    Member
    Posted 2 years ago #

    So it looks like as long as I can get this .htaccess file to play nice, my answer may be "yes"?

    Yes, and No. .htaccess isn't really what makes it work. .htaccess tells the server what to do once it does work.

    The answer to this question:

    will this be easy to configure once the site is live?

    ...pretty permalinks will only work if your server meets the requirements specifically mentioned for using pretty permalinks, in the documentation I pointed you to. So, if your web server meets the requirements, pretty permalinks will be a snap.

    You'd think it would be easier to get some pretty permalink structure going. It feels like the Wild West days of WordPress design when things like this happen

    The thing is, it's a server setup and configuration issue. Not really a WordPress issue. You must have a web server configuration that supports using pretty permalinks.

    The good news is, it actually is quite easy to use. If mod_rewrite is functioning properly, (which it probably will be, once you purchase hosting from a reputable company using a linux server environment) the only thing really you need to do is to make sure permissions on .htaccess are writable to WordPress when you make the changes. Then when you update permalinks from the dashboard, the changes will be made automatically in the .htaccess file. Once you are done making the changes, you simply return the permissions on the .htaccess file back to the secure settings, and you're done.

  5. ClaytonJames
    Member
    Posted 2 years ago #

    @schoolspeak

    You'd think it would be easier to get some pretty permalink structure going. It feels like the Wild West days of WordPress design when things like this happen

    I got a little curious as to why this seemed to be such an effort using WAMP. I'm not a fan of WAMP, so I rarely have any reason to mess with it.

    Just so we're on the same page, I installed this version (version 2.2) of WampServer //download.cnet.com/WampServer/3000-10248_4-10797035.html on an old XP box. I then installed WordPress. I immediately duplicated your 404 error by simply changing the permalinks in the dashboard. WordPress did write the correct .htaccess file perfectly with no intervention from me.

    The only thing I had to do to get pertty permalinks working on WAMP, was to click on the green WampServer icon in the system tray, select Apache > Apache modules > then scroll down the module list until you come to "rewrite_module", and place a check mark next to it. WordPress pretty permalinks started working instantly. I didn't even need to restart Apache. It did a graceful restart all on it's own. WampServer apparently does not load the rewrite module by default.

    I hope you have as much success with it as I did.

    Good luck to you!

Topic Closed

This topic has been closed to new replies.

About this Topic