WordPress.org

Ready to get started?Download WordPress

Forums

Easy Speak Mailing list problems (15 posts)

  1. danrich
    Member
    Posted 3 years ago #

    Hi

    I've just downloaded and activated the Easy Speak Mailing List plugin yet it doesn't seem to work. Nothing happens when I click "submit email".

    I've gone through the seemingly simple instructions to install the plugin, yet when I get to step 4 and attempt to "Set the desired destination email address in the Easy SPeak Settings page under the settings tab on the wordpress admin pages", there is no field for me to add my email address.

    The "Download your address book .csv file HERE" link doesn't seem to go anywhere either.

    I really don't want to vote that this doesn't work as I am very new to WordPress and don't want to criticise someone's free efforts when there's a more than good chance that the problem lies with me!

    Any help or guidance would be greatly appreciated.

    Dan

  2. tonyrambler
    Member
    Posted 3 years ago #

    Hi, I have half of the same problem!
    Dan - the solution to the "submit email" not working for me was to enable jquery in header.php, as my theme (plainscape) didn't have this by default.
    insert:
    <?php wp_enqueue_script("jquery"); ?>
    somewhere before:
    <?php wp_head(); ?>
    in header.php in the theme's folder.

    But I also can't get the .csv file - when i downloaded it i got a non-suffixed non-styled 404 page download instead! Any suggestions?

    Is there a way to utilise the addresses without downloading the .csv file?

    Tony

  3. lukeroberts1990
    Member
    Posted 3 years ago #

    Hi Dan, Hi Tony

    Ive just released a new version today and this should help as the file is no longer stored but created and sent using php and jquery at the click of a button!

    Your right Tony you do need Jquery installed and that is one way to do it, alternatively you can install my easy speak widget contact form plugin and enable jquery within the settings page for that if you dont want to mess with code!

    If you need any more assistance please dont hesitate to ask!

    Thanks Luke

  4. troubleonwheels
    Member
    Posted 3 years ago #

    Hey Luke, having similar problems here. I've loaded both Easy Speak Widget Contact Form and Easy Speak Mailing List plugins, and they're both active and showing up in the dashboard/settings area. My intent is to have a simple 'add your email address here to get added to my spam email file' form on the home page. I'm using the mailing list plugin to put the form inside the widget area on the home page of the website, and it shows up fine. However, when inputting an email and hitting submit, the form just basically goes away, and only the title is left. None of the follow up response expected. Inside the admin portion, if I select 'get user data' nothing happens. I've tried both with and without Jquery selected and have loaded both of these plugins today (so they're current). If you want to look: dirtcheaprally.com. I'm a newbie and partial-moron, so any help is appreciated.

    Thanks!

  5. lukeroberts1990
    Member
    Posted 3 years ago #

    hi troubleonwheels

    It seems like you havent set the thankyou message within the settings page

    navigate to settings->easy speak mailing list on the left hand sidebar within wp-admin
    should be somewhere near the bottom.

    In this page you can define the messages that replace the form, the form is intentionally hidden once submitted in order to prevent people clicking the button loads of times and just generally breaking scripts.

    If this works it would be great if you could let me know on here.

    Thanks

    Luke

  6. lukeroberts1990
    Member
    Posted 3 years ago #

    hi troubleonwheels

    It seems like you havent set the thankyou message within the settings page

    navigate to settings->easy speak mailing list on the left hand sidebar within wp-admin
    should be somewhere near the bottom.

    In this page you can define the messages that replace the form, the form is intentionally hidden once submitted in order to prevent people clicking the button loads of times and just generally breaking scripts.

    If this works it would be great if you could let me know on here.

    Thanks

    Luke

  7. troubleonwheels
    Member
    Posted 3 years ago #

    Luke,

    I have set the thank you message in both easyspeak widgets, and it continues to be saved and show whenever i access the widgets, even if I've logged out so I'm pretty sure it's saved somehow. It's very cool that the form hides itself to avoid repeat entries.

    At this point, I'm not able to get the 'thank you' message displayed to the user entering the data, and if the information is being stored somewhere clicking the 'get user data' doesn't do anything at all for exporting it to my defined email address.

    help? Thanks,

    Erik

  8. troubleonwheels
    Member
    Posted 3 years ago #

    One more thought I had - where should the data (email) be written? I've looked through my file system and can't find anywhere that easyspeak has created a database of any kind, so I'm wondering if it has write permissions where it would need them. Any guidance as to where to look and what permissions the files need to have (755?). Thanks again, this is the last hurdle on my website so I'm excited to get it all figured out.

    Erik

  9. lukeroberts1990
    Member
    Posted 3 years ago #

    hi troubleonwheels,

    To answer your first query the thank you messages are stored within the wp_options table.

    The addresses are stored within the wp_mailing_list table and a script generates the csv from there

    Unfortunately I cannot understand as to whats causing this crash within your website.

    Are you able to access the your database and find whether the addresses are being stored??

    Thanks Luke

  10. troubleonwheels
    Member
    Posted 3 years ago #

    Well, that could be part of the problem... I don't have a wp_options file nor a wp_mailing_list file anywhere in my site database. Should they have been created as part of the WP install, or as part of the plugin activation? I'm on WP 3.1.2. Where might they be, or what else might it be labeled?

  11. ihaveguts
    Member
    Posted 3 years ago #

    I Likeroberts1990,

    first of all thanks a lot for the plugin you wrote.
    Unfortunately I have 2 problems, one small one quite big.

    The small one is that even though i registered the thank you message in the wp options this does not show as the email is submitted and the email field disappears.

    The big one is that even though the wp_mailing_list table has been created in my db, as i submit a valid email adress the form disappears but no email is saved in the db table.

    I'm running jQuery 1.5 could that be the problem?

    Thanks a lot!

    Gabriele

  12. dcdc
    Member
    Posted 3 years ago #

    Hi Luke,

    I'm having similar issues to the others here on a new website I'm building.

    I have set up a thank you message in the plugin settings, and also installed your contact form plugin so that the jquery is installed.

    However, when submitting an e-mail address off the form, the form disappears and the thank you message does not display. I am also not able to retrieve the csv file via e-mail. When I click on that button in the plugin settings, it does nothing at all (the status bar in the browser just continues to say done).

    Unlike some of the others though, the e-mails submitted through the form are obviously posting to the database since I'm able to send out a test newsletter, which I receive.

    Any assistance you can provide would be much appreciated.

    Christopher
    [sig moderated as per the Forum Rules]

  13. lukeroberts1990
    Member
    Posted 3 years ago #

    Right to the last 3 people!

    It sounds like there is conflicts between other theme/plugin/javascript libraries going on specific to yourselves!

    I'm more than happy to help however as the plugin is so simple! its probably said conflict with your specific sites which as the plugin is fairly young hasnt encountered nd therefore doesnt cater for!

    email me at email@luke-roberts.info and we can discuss these issues in more detail as all these issues have slightly different symptoms.

    Sorry for the lack of a direct answer but I would rather analyse the situation thoroughly and then come up with a difinitive soloution before posting on here!

    cheers

    Luke

  14. mackan56
    Member
    Posted 2 years ago #

    Hi Luke.

    I've tried using both of your widgets now, but nothing seems to work. The mail list widget sends mails, the problem though is that the widget sends the mails via my hosts e-mail address (ie. DOMAIN@HOST.net instead of info@DOMAIN.se).

    I've checked it with my host, but they couldn't find anything wrong with the database or anything and thought it had something to do with the widget.

    So how do I go on about setting the mail list to send mails through the correct mail, ie. the one that's set as the admin accounts e-mail address?

    Thanks in advance!

  15. lukeroberts1990
    Member
    Posted 2 years ago #

    This plugin is no longer supported please don't email me regarding this plugin any more. I simply do not have the time. Any one is welcome to take their existing installation and so with it what they will. Have fun!

Topic Closed

This topic has been closed to new replies.

About this Topic