WordPress.org

Ready to get started?Download WordPress

Forums

fancybox
Easy fancybox and tablepress (8 posts)

  1. ouverz
    Member
    Posted 1 year ago #

    Hi there,

    I've been trying to hav easy fancybox and tablepress work together and display an image gallery in a nice table (4 columns, 3 rows).
    For a reason I can't understand, since I started using tablepress plugin, easy fancybox doesn't work for me, when I click an image in the table i've created it just links to a seperate page with the image.
    this is the code displayed in each td -
    <img src="http://localhost/wordpress/wp-content/uploads/2013/04/image4-150x150.jpg" alt="" width="150" height="150" class="alignnone size-thumbnail wp-image-86" />

    Any help would be much appreciated.

    Ofer

    http://wordpress.org/extend/plugins/fancybox/

  2. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    thanks for your question, and sorry for the trouble.

    I'm not exactly sure, but this might be caused by the TablePress table output caching. That might be preventing the FancyBox JS from being loaded. Therefore, please try changing your table Shortcode to

    [table id=123 cache_table_output=false /]

    If that does not help, I'd need to take a direct look at the page with the table, so please post a link then. Thanks!

    Regards,
    Tobias

  3. ouverz
    Member
    Posted 1 year ago #

    Hi Tobais,

    Thanks for the reply, I tried adding the shortcode but still no luck. The site is not live, so wouldn't that present a problem. I don't see how I can send you a link to see for yourself.

    any ideas would be awesome.

    Regards,
    Ofer

  4. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    ah, that's unfortunate :-( Then I'd really need to see the page with the table.

    With "not live", do you mean that it's running on a local development server? Or is it on a server in the Internet already? Could you then maybe create a temporary account for me and send me the information via email (my address is in the main plugin file "tablepress.php")?

    Regards,
    Tobias

  5. ouverz
    Member
    Posted 1 year ago #

    I mean its on a local development environment, so I guess there's no way of having you look at it.
    I do appreciate your willingness to help.

    I'll let you know if I find a solution or when the site is live.

    Thanks again

  6. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    ok, thanks for the clarification. Yes, then there's really nothing that I can do, until the site is live. Sorry.

    Meanwhile, just to make sure that the problem is not coming from something else, I suggest to try again after temporarily deactivating all plugins except TablePress and Easy Fancybox, and switching to the WordPress default theme.

    Regards,
    Tobias

  7. RavanH
    Member
    Posted 1 year ago #

    Hi ouverz,

    when I click an image in the table i've created it just links to a seperate page with the image

    Do you mean it opens a WordPress generated attachment page or does it open the image directly in the browser tab?

    Could you paste that code that is inside each table cell again, this time using the CODE button above the reply field?

  8. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    from ouverz link in the first post, I assume that the link goes to the attachment page.
    So, that might indeed be a reason, I think, if the link should go to the actual image.

    Regards,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic