WordPress.org

Ready to get started?Download WordPress

Forums

Easing Slider IE 9 issues (35 posts)

  1. Mark
    Member
    Posted 2 years ago #

    Hi Guys

    Wonder if you can help. I am running Easing Slider plugin on my website Click here but the slideshow images are not loading in Internet Explorer 9. I have tried switching the Load jQuery? to true and false but no luck.

    Any ideas on how to get this to work in IE 9?

    Thanks

  2. HLISM
    Member
    Posted 2 years ago #

    I have the same issue??

    FYI Your site looks great in Google Chrome!

  3. Mark
    Member
    Posted 2 years ago #

    Any good alternatives

  4. geoffgraham
    Member
    Posted 2 years ago #

    I'm having the same issue and also tried toggling Load jQuery between true and false with no luck.

    Images load perfectly for me in all browsers (including IE7/8) but nothing loads in IE9.

    You can see the issue on my site.

    Anyone know if this is a bug with the plugin or a conflict in our code? I'm running WP 3.1.2 and Easing Slider 1.1.7.

    Thanks

  5. Mark
    Member
    Posted 2 years ago #

    glad to see I am not the only one. I wish we could get some clarification, because I am stumped. This isnt the only website I am using the plugin on.

  6. Mark
    Member
    Posted 2 years ago #

    I have loaded the hybrid slideshow in the meantime, but I would like to know the cause of the problem is.

  7. jratoms
    Member
    Posted 2 years ago #

    Under slider settings, have you tried changing your preloadIcon to none?

  8. HLISM
    Member
    Posted 2 years ago #

    Yes, same results, no slideshow in IE9

  9. DaGieltje
    Member
    Posted 2 years ago #

    Hi!

    I have the same issue and i have also problems with Firefox 4.0..

  10. geoffgraham
    Member
    Posted 2 years ago #

    Thanks, @jratoms. Changing the preloadicom to none did the trick for me.

    Appreciate your help!

  11. onkar_cuelogic
    Member
    Posted 2 years ago #

    Hi Guys,

    I am still facing the issue.
    preloadicon to none, does not solve my problem.

    Any update?

  12. mattchstik
    Member
    Posted 2 years ago #

    I also am facing this issue. Changed preload icon, turned off load jQuery, and double checked all my image urls. Any word? Thanks,

  13. Mark
    Member
    Posted 2 years ago #

    Still have the issue on my other websites. Would be great to get this resolved. The old version of this works on IE 9 just not the latest version.

  14. mallsop
    Member
    Posted 2 years ago #

    I have the same IE9 issue. I contacted the plugin creator who is aware of this issue and is looking into this.
    As a test, I tried an extra page reload for IE9 but it did not fix it.

  15. mattchstik
    Member
    Posted 2 years ago #

    I also contacted the author. Was told it may be a month or so until this might be fixed with an update but not for sure.

  16. mallsop
    Member
    Posted 2 years ago #

    I think I found a solution:

    Add this in your html head
    <meta http-equiv="X-UA-Compatible" content="IE=8"/>

    I saw that google was doing that.

  17. mattchstik
    Member
    Posted 2 years ago #

    mallsop: I tried using that, to no avail.

  18. MatthewRuddy
    Member
    Posted 2 years ago #

    Try the following. Should work for IE9 32-bit & 64-bit.

    Add it before the final </head> in your theme's header.php file (or the appropriate file).

    <?php $browser = $_SERVER['HTTP_USER_AGENT'] . "\n\n";
    	$search = strpos( $browser, 'Win64' );
    	if ( $search != false && $search != 0 && $search != '' ) {
    		// This is for IE9 64-bit.
    		echo '<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8"/>';
    	} else {
    		// And this is for IE9 32-bit.
    		echo '<meta http-equiv="X-UA-Compatible" content="IE=8"/>';
    } ?>
  19. mattchstik
    Member
    Posted 2 years ago #

    Still doesn't seem to do the trick. My slider is still not loading in IE9

  20. Chris
    Member
    Posted 2 years ago #

    I am having the same exact problem. In IE9 64bit it is not working on this site: http://honestpt.moorewebexposure.com/ However on two other sites I am using it on it is working: http://www.lightthebridges.org/ and http://www.laurelstonesoaps.com/. Very strange. Hope the developer releases a fix soon!

  21. mallsop
    Member
    Posted 2 years ago #

    yeah i thought it would work. dang. thinking what else todo...

  22. Eric Hoanshelt
    Member
    Posted 2 years ago #

    Go to wp-content/plugins/easing-slider/js/ and find the js file named slider.js. On line 36, you will find:
    isPreloaded: true

    Change that to

    isPreloaded: false

    Should work for IE9 then.

  23. markarian
    Member
    Posted 2 years ago #

    Yes - that's the fix! Well done ehoanshelt. The other fixes weren't working consistently for me.
    Seems to be in a file called script.js though.
    Hopefully that will get included in an update?

  24. Eric Hoanshelt
    Member
    Posted 2 years ago #

    my applogies, I meant to type script.js.

    SOLUTION:

    • Go to wp-content/plugins/easing-slider/js/script.js
    • Go to line 36 and find isPreloaded: true
    • Change to isPreloaded: false

    This is the fix until the developer updates the plugin

  25. mallsop
    Member
    Posted 2 years ago #

    That fix worked. Thanks!

  26. mattchstik
    Member
    Posted 2 years ago #

    Finally, a solution. Thanks ehounshelt, it worked!

  27. Maikel
    Member
    Posted 2 years ago #

    Thanks ehoanshelt, finally I solved this problem!

  28. webaware
    Member
    Posted 2 years ago #

    @ehoanshelt, thanks for the fix! To make it more selective, so that it only sets isPreloaded to false on IE9, try this one:

    isPreloaded: !(document.documentMode && document.documentMode == 9)

  29. MatthewRuddy
    Member
    Posted 2 years ago #

    All IE9 issues have been fixed with the 1.1.8 update. Make sure you install it asap! Enjoy.

  30. webaware
    Member
    Posted 2 years ago #

    Great stuff Matthew, thanks. Haven't tested in IE9 yet, but will soon. However, please note that you have not updated the version information in add_scripts and add_styles -- still set at 1.1.7, so no forced reload of scripts or styles.

Topic Closed

This topic has been closed to new replies.

About this Topic