WordPress.org

Ready to get started?Download WordPress

Forums

E-mail to blog problem - mail not being posted (11 posts)

  1. David Kahn
    Member
    Posted 2 years ago #

    I have set up my e-mail account from which to send mail
    xxxx@portelizabethbnbaccommodation.co.za
    I have set my control panel to receive from this address and set the port to 110 (correct according to my host (hostgator)

    I have added this code to the footer:

    <iframe src="http://portelizabethbnbaccommodation.co.za/wordpressinstalldir/wp-mail.php" name="mailiframe" width="0" height="0" frameborder="0" scrolling="no" title=""></iframe>

    But the mail does not get posted.

    Can you assist please.

  2. Brad Markle
    Member
    Posted 2 years ago #

    Hi vonkie. If your iframe, you have:

    src="someURL"

    If you visit that URL, what result do you see?

    Also, I visited http://portelizabethbnbaccommodation.co.za/ and when I looked at the source code I did not see any iframes (which it sounds like that's the blog you're referring to?).

  3. Brad Markle
    Member
    Posted 2 years ago #

    Hi vonkie, where you ever able to make any progress on your post by email issue?

  4. David Kahn
    Member
    Posted 2 years ago #

    Hi Brad

    Thank you for your feedback, and I apologize for my slow reply - life is too hectic.

    I have re-visited the footer and:

    <iframe src="http://portelizabethbnbaccommodation.co.za/wordpressinstalldir/wp-mail.php" name="mailiframe" width="0" height="0" frameborder="0" scrolling="no" title=""></iframe>

    had disappeared (me to blame) but I have added it again.

    When I run the test using Postie, the mail is still not published.

    Not sure where to go. I am building (trying) this site for my aged parents who run a small bnb.

  5. Brad Markle
    Member
    Posted 2 years ago #

    Your iframe is set currently to:

    http://http://portelizabethbnbaccommodation.co.za/my-favourite-recipes//wordpressinstalldir/wp-mail.php

    If you notice, you have "http://" in there twice, which is one problem.

    Also, I don't believe you actually need "wordpressinstalldir" in it. Most likely the url should be:

    http://portelizabethbnbaccommodation.co.za/wp-mail.php

    I do however get an error message when testing that URL. Do you have a link to the page that tells you how to setup the iframe?

  6. David Kahn
    Member
    Posted 2 years ago #

    The iframe instruction is here (under 'automated browser...') http://codex.wordpress.org/Post_to_your_blog_using_email

    I have just updated the iframe correction as per your advice but still no success.

  7. Brad Markle
    Member
    Posted 2 years ago #

    When I visit this url:

    http://portelizabethbnbaccommodation.co.za/wp-mail.php

    I get this error:

    POP3 connect: Error [0] [php_network_getaddresses: getaddrinfo failed: Name or service not known]

    In the link provided, what host did you enter for:

    Step 2 - Configure WordPress to access your new account

    If you used portelizabethbnbaccommodation.co.za, please try using instead "localhost" (without the quotes).

  8. David Kahn
    Member
    Posted 2 years ago #

    I changed to "localhost" (without the quotes)on the writing pane - still no luck.

    Then Tried to change mail.portelizabethbnbaccommodation.co.za to "localhost" (without the quotes)as well, but still no luck.

    Is there a secure way that I can give access to the site to save time?

  9. Brad Markle
    Member
    Posted 2 years ago #

    I'd be happy to review this further to see if I can get it working for you. If you would like for me to do this, you can email me further details at bradm@inmotionhosting.com

  10. Brad Markle
    Member
    Posted 2 years ago #

    Hi David.

    I think we got this one resolved! The issue I noticed was that the username was not set to a full email address. After updating this in your "Writing" settings in your dashboard, going to wp-mail.php (the iframe link) I now see that it appears to be processing the emails. Please take a look and let me know if it now appears to be working for you.

  11. David Kahn
    Member
    Posted 2 years ago #

    Hi Brad

    Thank you - I see that the tests that I have sent are pending - and have now corrected my setting in 'Postie' to authorise them as 'published'.

Topic Closed

This topic has been closed to new replies.

About this Topic