WordPress.org

Ready to get started?Download WordPress

Forums

E-Mail from Contact Form (19 posts)

  1. beamon
    Member
    Posted 1 year ago #

    I am a newbie and am attempting to set up my first website using WordPress. The host server I chose is Dreamhost.

    I added a contact form to the website, actually have tried adding several. I cannot send a message successfully via the form. It will say "the message has been sent successfully" but I never get the message. I checked my SPAM folder and it is not there.

    Could Dreamhost settings be the cause? I made an attempt to set up settings in Dreamhost -- but still have not received a message.

  2. andy2grant
    Member
    Posted 1 year ago #

    might be your plugin is not properly working . Check its settings

  3. beamon
    Member
    Posted 1 year ago #

    Hi Andy,

    How do you check the plugin settings? Do I need to know code for this?

  4. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    We have extra rules at DreamHost about email. The short version is that if you're trying to send email via a form from an address that isn't the same as your domain, it won't work out of the box.

    Usually these directions sort people out: http://elftest.net/contact-form-7-and-anti-spam/

  5. beamon
    Member
    Posted 1 year ago #

    Mika - I do have the Configure SMTP installed. Could there be something else I need to reset?

  6. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Try entering the SMTP details for the email address that's being used.

  7. beamon
    Member
    Posted 1 year ago #

    Where exactly, Mika.

  8. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

  9. beamon
    Member
    Posted 1 year ago #

    I have made sure username is my gmail address and password is my gmail password. I am not sure what needs to be changed as far as the host, port, secure prefix. Currently they are set to smtp.gmail.com, 465, ssl.

    When I do a test it says it cannot authenticate.

  10. beamon
    Member
    Posted 1 year ago #

    After the "cannot authenticate" message, I got a message from gmail saying there was suspicious activity my gmail account.

    Since I simply want to "receive" a message from someone filling out the contact form, why is gmail warning me that someone is trying to hijack my account?

  11. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    When you say you're using gmail, are you using a you@gmail.com email, or do you have the (now pay-for only) gmail hosted email so it's you@yourdomain.com but runs through Gmail?

    It does matter to how you set up that plugin.

  12. EllisInternational
    Member
    Posted 1 year ago #

    I am having a very similar problem, but hosting on Verio rather than dreamhost. The forms can be completed through our mobile verison, hosted by Dudamobible, but are never seen when completed on a desktop.

  13. beamon
    Member
    Posted 1 year ago #

    I have had a gmail account for a long while.

    The problem is this - between Dreamhost, WordPress, and the Contact Form settings there are emails everywhere! How does a new person know what email to use for each of these fields that needs to be populated? Dreamhost even has two different areas related to emails -

    I'm not sure what emails are supposed to be in what fields and what the consequences are for filling them out a certain way.

    Do you know of documentation that spells out how all of these pieces come together to make the system work the way it is supposed to?

    This is very frustrating for some of us.

  14. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    I get that you're confused, and I'm sorry. I don't have the puzzle pieces to give you an exact answer, though. That's why I asked what kind of email you're using.

    What does them email address you're trying to send email to look like? Does it end in gmail.com OR does it end in yourdomain.com? :)

    That's what I need to know to give you the answers.

  15. beamon
    Member
    Posted 1 year ago #

    Thanks, Mika.
    My gmail is formatted like this me@gmail.com. Since I am not sure where to pick up the messages going to yourdomain.com, I was trying to have them forwarded to me@gmail.com.

    But, in a perfect world, since this website will be business-related, it would be best to have the messages go to a place where they can be grouped together and not to my personal me@gmail.com.

  16. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Righton.

    For an @gmail.com account, there's a box on the SMTP plugin that says 'Send Email via Gmail' (see http://s.wordpress.org/extend/plugins/configure-smtp/screenshot-1.png?r=660916 for a screenshot)

    Then for your SMTP username, you use USERNAME@gmail.com

    It should look like this:

    http://cl.ly/image/3C1t3S0q0E0b

  17. Ron Bado
    Member
    Posted 1 year ago #

    Hello Mika:

    I have been working with beamon on this, and made all necessary changes, with still no success. I think we are using us@ourdomain.com and are having the anti spam problem. How do we get out of that?

  18. Ron Bado
    Member
    Posted 1 year ago #

    We even followed the intsrtuctions on http://elftest.net/contact-form-7-and-anti-spam/

  19. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Ron, sometimes people have to fill in the SMTP settings.

    SMTP Host: mail.ourdomain.com
    Port: 25

    Check the box for SMTP Auth and put in your username as us@ourdomain.com (and your password, obviously).

    Does that work?

Topic Closed

This topic has been closed to new replies.

About this Topic