WordPress.org

Ready to get started?Download WordPress

Forums

E-commerce plugin - fatal error (6 posts)

  1. Flusher
    Member
    Posted 6 years ago #

    I uploaded WordPress, and installed it, it works like a charm. But when i uploaded the WP e-commerce (http://www.instinct.co.nz/e-commerce) plugin, and try to activate it, i get the following error: Plugin could not be activated because it triggered a fatal error.

    Can anyone give me some hints on what to do? :)

    Here is the phpinfo from the server where it's hosted:

    System FreeBSD web23416.talkactive.net 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007 root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP i386
    Build Date May 30 2007 13:23:59
    Configure Command './configure' '--enable-versioning' '--with-layout=GNU' '--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all' '--enable-libxml' '--with-libxml-dir=/usr/local' '--enable-reflection' '--program-prefix=' '--enable-force-cgi-redirect' '--enable-fastcgi' '--with-apxs2=/usr/local/sbin/apxs' '--with-regex=php' '--with-zend-vm=CALL' '--prefix=/usr/local'
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /usr/local/etc
    Loaded Configuration File /usr/local/etc/php.ini
    Scan this dir for additional .ini files /usr/local/etc/php
    additional .ini files parsed /usr/local/etc/php/extensions.ini
    PHP API 20041225
    PHP Extension 20060613
    Zend Extension 220060519
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    IPv6 Support enabled
    Registered PHP Streams php, file, data, http, ftp, https, ftps, zip, compress.zlib
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
    Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*

  2. TechHelp
    Member
    Posted 6 years ago #

    I am having the same problem exactly. Have you had any luck solving it? I've done clean installs of everything and still no change.

  3. TechHelp
    Member
    Posted 6 years ago #

    PROBLEM SOLVED!!!
    =================

    It was a memory problem.

    Simply increase the php.ini memory allocation. It is set at 8MB by default. I upped mine to 32MB and I was up and running.

    Everything works perfectly.

    Great plugin. Thanks Instinct folks!

    Good on ya : )

  4. regenboogmama
    Member
    Posted 6 years ago #

    And how do you increase the php.ini memory allocation? I have the same problem now...

  5. whooami
    Member
    Posted 6 years ago #

  6. jeanjacques
    Member
    Posted 6 years ago #

    Hi,
    I have the same problem as described above, unfortunately i already have 32 mb in my php.ini

    Should i do something else?

Topic Closed

This topic has been closed to new replies.

About this Topic