WordPress.org

Ready to get started?Download WordPress

Forums

e-commerce gold install php errors (1 post)

  1. PaulGuise
    Member
    Posted 7 years ago #

    Hi All,

    I have a fresh install of WP 2.1 and the e-Commerce plugin Gold version.
    On the front end, everything works great.
    On the backend though, here is a sample of what I am coming across.

    When i try to add a new product with image:

    Warning: mkdir() [function.mkdir]: No such file or directory in [ROOT_REMOVED]developmentwp-contentpluginswp-shopping-cartdisplay-items.php on line 154
    
    Warning: copy([ROOT_REMOVED]developmentwp-admin/wp-content/plugins/wp-shopping-cart/product_images/walkInThePark.jpg) [function.copy]: failed to open stream: No such file or directory in [ROOT_REMOVED]developmentwp-contentpluginswp-shopping-cartdisplay-items.php on line 170
    
    Fatal error: Call to undefined function imagecreatefromjpeg() in [ROOT_REMOVED]developmentwp-contentpluginswp-shopping-cartimage_processing.php on line 11

    When I add a category image:

    Warning: move_uploaded_file([ROOT_REMOVED]developmentwp-admin/wp-content/plugins/wp-shopping-cart/category_images/orangjulius.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in [ROOT_REMOVED]developmentwp-contentpluginswp-shopping-cartimage_processing.php on line 75
    
    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '[ROOT_REMOVED]PHP_TEMPphpA.tmp' to '[ROOT_REMOVED]developmentwp-admin/wp-content/plugins/wp-shopping-cart/category_images/orangjulius.jpg' in [ROOT_REMOVED]developmentwp-contentpluginswp-shopping-cartimage_processing.php on line 75

    [ROOT_REMOVED] is for security's sake.

    Errors like this occur when ever I add new products or categories or anything that has (or may have) an image associated to it.

    The site is at http://development.igonzo.com

    The site is running on a windows 2003 server using IIS. PHP v 5.1.5 is running through IIS as a service. I have about 15 sites that run WP and PHP just fine but this is a first for me.

    Ive tried hacking a few of the files (replacing / with \ in paths, commenting out mkdir for already created folders) but these have not yielded any results.

    Are there any suggestions out there? Is my PHP install faulty? Should I get 5.2.1?

    Thanks all, and sorry for the long read.
    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic