WordPress.org

Ready to get started?Download WordPress

Forums

DynamiX Theme on WP 3.2.1 (4 posts)

  1. Nigel
    Member
    Posted 2 years ago #

    We're using DynamiX 2.5 on WP 3.2.1. It runs okay in our dev environment but when we push it to production it runs for a few hours then users start hitting it, the server CPU maxes out.

    We're using a multi-level sub menu widget, and few plugins:
    s2member, Contact Form 7, Global Content Blocks, Sniplets, Tiny MCE Advanced, TS Custom Widgets, WP Cufon, and Super Cache.

    Anyone had a similar problem, or have any ideas? Thanks in advance.

  2. analogrithems
    Member
    Posted 2 years ago #

    Ok first thing, what is your URL?

    Second ditch Super Cache and replace with W3 Total Cache. It gives much more control like minify CSS & javascript and utilizing PHP cache systems like APC or memcache.

    Next, if this is hosted on your own server, consider turning up the ammount of memory available to your wordpress instance in your php.ini (for linux this is under /etc/php.ini remember to recycle apache afterwards) I usually set mine to give PHP 128Mb for a production site. Remember memory is cheap, your time isn't!

    Also if your doing your own hosting make sure you've installed APC cache. It really improves PHP all around performance. If your slowness us being caused by really high traffic. Then it's time to consider load balancing your site or at the very least using a CDN (Content Delivery Network) to serve your files.

    If you are not the one hosting the site, then perhaps it's time to consider switching hosting providers. I think in this crowd you'll find Dreamhost is among the favorite, and not just because they support WordCamps!

    -Analog

    -Analog

  3. Nigel
    Member
    Posted 2 years ago #

    Thanks for the ideas analogrithems, good info. Email me at nduckworth at the domain gmail and I'll email you the URL for the dev site.

    Thanks again!

  4. chronographics
    Member
    Posted 2 years ago #

    I'm also using the dynamixtheme.

    and I have a big problem with the dynamic galleries. they just won't work. all I see is the frame and a broken picture sign.

    I installed the theme via Filezilla, cause otherwise it didn't work. now everything is running except the galleries. do I have to save my pictures somewhere special?
    I also tried external pictures, nothing worked, EXCEPT the thumbnails from Flickr.com (don't ask me why and how)

    I have my webspace at 000webhost.com if this information is neccessary?

    Thanks for any help!!

Topic Closed

This topic has been closed to new replies.

About this Topic