WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Dynamic Widget Sidebar Markup not updating (2 posts)

  1. Demetreas
    Member
    Posted 3 years ago #

    Hi, I've seen a few of these posts listed but they all say the same thing and I've tired the solution but that's not working.

    I have 3 dynamic widget based sections to my site, and I want to change the surrounding markup from the default list style to a simple surounding div and the h2 tag from the title to a h3 tag.

    on my pages I have

    <?php 	/* Widgetized sidebar, if you have the plugin installed. */
    if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar(2) ) : ?>
    
    <?php endif; ?>

    !dynamic_sidebar(2) (this number changing depending on what set of widget I want to appear there.

    and in my functions php I've tried all sorts of combinations of setting out the below and nothing changes it still displays the list style

    if ( function_exists('register_sidebar') ){
        register_sidebar(1, array(
            'before_widget' => '<div class="clearfix">',
            'after_widget' => '</div>',
            'before_title' => '<h3>',
            'after_title' => '</h3>',
        ));
    	    register_sidebar(2, array(
            'before_widget' => '<div class="clearfix">',
            'after_widget' => '</div>',
            'before_title' => '<h3>',
            'after_title' => '</h3>',
        ));
    		register_sidebar(3, array(
            'before_widget' => '<div class="clearfix">',
            'after_widget' => '</div>',
            'before_title' => '<h3>',
            'after_title' => '</h3>',
        ));
    }

    no matter what I change from my functions.php nothing changes on the widgets but if i take this section out completely I lost the use of widgets altogether which means it is reading the functions.php only ignoring the array?

    Thanks in advanced for any help given, and if I'm being blind to something obvious sorry lol.

  2. Demetreas
    Member
    Posted 2 years ago #

    This issue has been resolved with the latest wordpress updates.

Topic Closed

This topic has been closed to new replies.

About this Topic