WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic menu (or any menu!) not working in Firefox (7 posts)

  1. hurky195
    Member
    Posted 4 years ago #

    Hi,

    Not sure if this is the right place to post this but hopefully it is. I'm pulling my hair out with a dynamic menu on my WordPress site (http://www.enpointeconsulting.com.au) that works as it should in all major browsers apart from Firefox. The two menus that aren't working are the main menu at the top and the category menu immediately under the header. In Firefox, nothing happens when you click on the navigation links.

    I have checked the validation on the page and the css and everything with the navigations seems to be OK. I've even tried replacing the dynamic menu with a simple menu and it still doesn't work.

    Hopefully someone can steer me in the direction of a solution.

  2. robinvd
    Member
    Posted 4 years ago #

    Might have found something..

    In your topmenu all buttons are linking to yourwebsite.au/about .. instead of yourwebsite.au/about/ .. put an extra '/' .. it might work.

  3. hurky195
    Member
    Posted 4 years ago #

    Good thinking and thanks, but unfortunately that doesn't work either. I've inserted part of what I presume is the offending php script below (which is included in header.php). Hopefully someone else can point out the error of my ways!

    <li<?php
    if (is_page('Marketing communications for your small business'))
    {
    echo " id=\"current\"";
    }?>>
      Home  

    <li<?php
    if (is_page('about'))
    {
    echo " id=\"current\"";
    }?>>
    /about/">  About Us 

    <li<?php
    if (is_page('services'))
    {
    echo " id=\"current\"";
    }?>>
    /services/">  Services 

    <li<?php
    if (is_page('portfolio'))
    {
    echo " id=\"current\"";
    }?>>
    /portfolio/">  Portfolio 

    <li<?php
    if (is_page('contact-us'))
    {
    echo " id=\"current\"";
    }?>>
    /contact-us/">  Contact Us 

  4. robinvd
    Member
    Posted 4 years ago #

    Ok wait.

    What version are you using atm? 3.0 or 2.9.2? Are you using the newest menu? Why make all kind's of lists instead of the simple line below:
    <div id="access"><?php wp_nav_menu( array( 'sort_column' => 'menu_order', 'container_class' => 'menu-header' ) ); ?></div>

    You still need to edit a few things. The menu is working perfect on my website this way.

  5. hurky195
    Member
    Posted 4 years ago #

    Hi again,

    I'm far from an expert in php so I'm not sure how to edit your suggestion to make it workable. However, one thing I have tried is replacing the dynamic menu with a simple menu (below). This too didn't work.

    <?php
    wp_list_pages('depth=1&exclude=416,414,411,133,124,57,126,130,128,54,59&sort_column=post_title&title_li='); ?>

    I am using version 2.9.2.

    Thanks heaps for your help so far.

  6. hurky195
    Member
    Posted 4 years ago #

    Just something to add to the all this (or maybe confuse things more), I've actually had the links work at times. For example, when I clicked on About Us it's taken me to the About Us page, although my excitement at this small success has been rudely taken away when the success doesn't replicate.

  7. hurky195
    Member
    Posted 4 years ago #

    OMG - I've solved the problem. It had nothing to do with the menu. The issue seems to have been caused by a plug-in I was using to rotate images through the header. I'd love to have the rotation but the navigation works without it, and for now that's all I care! Thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic