WordPress.org

Ready to get started?Download WordPress

Forums

During database upload I get "The connection to server was interrupted" (3 posts)

  1. G-Olly
    Member
    Posted 1 year ago #

    Hi there,

    I have been trying to upload my database backup via phpMyadmin. I have created a new database and keep trying to import my backup into it. In the first dialogue screen after hitting import, I have had this box checked, and unchecked: Allow the interruption of an import in case the script detects it is close to the PHP timeout limit. (This might be a good way to import large files, however it can break transactions.)

    Which ever I keep getting this error whilst uploading the .sql file which is 10,444 KB:

    This web page is not available
    The connection to server.net was interrupted.
    Here are some suggestions:
    Reload this web page later.
    Check your Internet connection. Reboot any routers, modems or other network devices that you may be using.
    Add Google Chrome as a permitted programme in your firewall or antivirus software's settings. If it is already a permitted programme, try deleting it from the list of permitted programmes and adding it again.
    If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server, adjust your proxy settings: Go to the Chrome menu > Settings > + Show advanced settings > Change proxy settings... > LAN Settings and deselect the "Use a proxy server for your LAN" checkbox.
    Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

    I have looked at the documentation and it gives the following advice:

    Starting with version 2.7.0, the import engine has been re–written and these problems should not occur. If possible, upgrade your phpMyAdmin to the latest version to take advantage of the new import features.

    The first things to check (or ask your host provider to check) are the values of upload_max_filesize, memory_limit and post_max_size in the php.ini configuration file. All of these three settings limit the maximum size of data that can be submitted and handled by PHP. One user also said that post_max_size and memory_limit need to be larger than upload_max_filesize.

    I have contacted my hosts and asked for any advice - i.e. can they increase these values - will this allow the upload to take effect and if not what else can I do?

  2. curlybracket
    Member
    Posted 1 year ago #

    10 megabytes might be a bit heavy for some servers/connections.
    Try to compress your file (ZIP or TAR.GZ) before uploading. PhpMyAdmin will be able to decompress it after you uploaded it.

  3. G-Olly
    Member
    Posted 1 year ago #

    Thanks Curly, I will give it a go as a compressed file. Will let you know the outcome.

Topic Closed

This topic has been closed to new replies.

About this Topic