WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Duplicator Settings msg: shell_exec not enabled (7 posts)

  1. caileenski3
    Member
    Posted 5 months ago #

    I'm a past FORTRAN programmer, new to WordPress. Pretty cool!

    I have used Duplicator successfully on my personal WordPress site on Bluehost. Now I'm trying to use Duplicator on another WP site. On this site, my only access is through the site Dashboard - no cPanel, no FTP access.

    Duplicator > Settings gives this message on the Database Build line:
    'This server does not have shell_exec configured to run.
    Please contact the server administrator to enable this feature.' The Diagnostics page says 'Shell Exec Not Supported.'

    I've deactivated, deleted, re-installed, and re-activated Duplicator.

    I contacted the server administrator. He says he doesn't know why that message is coming up and I should just run Duplicator anyway.

    Can anyone confirm that this is a good idea? Goes against my instincts. Thanks!

    https://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 5 months ago #

    Hey Caileenski,

    Basically shell_exec is not required to run the plugin, its just an extra option that allows for support like mysqldump. If its not enabled on your server and you want to try and use tools like mysqldump then you will need to contact the hosting provider and have the enable it for PHP.

    Cheers~

  3. caileenski3
    Member
    Posted 5 months ago #

    That's great! Thanks so much.

  4. caileenski3
    Member
    Posted 5 months ago #

    Success! This software is much appreciated.

  5. Cory Lamle
    Member
    Plugin Author

    Posted 5 months ago #

    Thanks! Hope it helps save you some time...

    Cheers~

  6. donnaWPadmin
    Member
    Posted 3 months ago #

    I keep trying to use the plugin, and keep getting exception errors. (and access denied, but I checked all my file & folder settings, all my htaccess files, php.ini...I can't find what is causing the errors. AND I turned off all website security. Windows server, WP ...latest version as is PHP.

    Fatal error: Uncaught exception 'UnexpectedValueException' with message 'DirectoryIterator::__construct(D:/Hosting/5877310/html,D:/Hosting/5877310/html) [directoryiterator.--construct]: Access is denied. (code: 5)' in D:\Hosting\5877310\html\wp-content\plugins\duplicator\classes\package.archive.php:108 Stack trace: #0 D:\Hosting\5877310\html\wp-content\plugins\duplicator\classes\package.archive.php(108): DirectoryIterator->__construct('D:/Hosting/5877...') #1 D:\Hosting\5877310\html\wp-content\plugins\duplicator\classes\package.archive.php(93): DUP_Archive->runDirStats('D:/Hosting/5877...') #2 D:\Hosting\5877310\html\wp-content\plugins\duplicator\views\actions.php(63): DUP_Archive->GetStats() #3 [internal function]: duplicator_package_scan('') #4 D:\Hosting\5877310\html\wp-includes\plugin.php(470): call_user_func_array('duplicator_pack...', Array) #5 D:\Hosting\5877310\html\wp-admin\admin-ajax.php(82): do_action('wp_ajax_duplica...') #6 {main} thrown in D:\Hosting\5877310\html\wp-content\plugins\duplicator\classes\package.archive.php on line 108

    Any help??? Please...I don't have a lot of time to back up this site before I lose it cause I am changing to a Linux server, and when the Windows server shuts down, nothing will be accessible. (I have manual backups of everything, but I've changed servers before, and uggh. I've heard so many positive things about this plugin how easy it makes it...but not if it's not working for me...)

  7. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    Hey @donnaWPadmin,

    Thanks for the feedback! If you can give the developer version a try it may have your fixes for the issue your seeing. The very latest version (0.5.3) can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues...

    Let me know if this solves your issue...

    If this is mission critical I would consider a commercial plugin like BackupBuddy this is still a beta product so it does have limitation on some systems...

    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic