WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Duplicator Package will not download (18 posts)

  1. zzzmuzz
    Member
    Posted 7 months ago #

    I have successfully used Duplicator and have been able to download both the installer and the Package.

    However on this one site of about 50MB, the installer and package are created ok, but when I go to download the package I get the error:

    403 Forbidden
    Access to this resource on the server is denied! Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    The system check only shows up two issues:
    Open Base Dir: On Fail
    and
    Cached Data:
    Cache Directory Not Found (which is surely not an issue).
    The Prezip overview shows: Pre-Zip Overview: 187.89MB 4,291 Files, 418 Folders

    All of the other packages I have downloaded have been with same settings, same server, same php version, same theme, and pretty much same plugins.

    To overcome the download problem I have deactivated all plugins (except Duplicator obviously), but this made no difference.
    I have changed PHP version from native, and chosen PHP 5.2 and clicked on zip and mysqli. This did not fix the issue.
    I am not 100% sure on where the "package" file is stored on my server. (this is Vodahost, with Cpanel).

    I have taken hours trying to sort this out and researched every related post I could find. Iwould just love to get this last site downloaded so I can work on it locally.

    Thanks for any help!

    http://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 7 months ago #

    Hey Zzzmuzz,

    If Open Base Dir is failing then that means it is turned on and that is would could be causing the issues your seeing. Work with your server admin to temporarily get it disabled and see that resolves the issue...

    Cheers~

  3. zzzmuzz
    Member
    Posted 7 months ago #

    I can get the Open Base Dir setting changed with Vodahost and am now working on getting the timeout changed from 60 seconds. They are not very keen though.

    I note that in your FAQ (3.10. What can I try for timeout issues ) you mention you can add: php_value max_execution_time 0 to the htaccess or the Duplicator folder. I tried it with the htaccess and nothing happened but how or where do I put it in the Duplicator folder?? In a text file or what?

  4. Cory Lamle
    Member
    Plugin Author

    Posted 7 months ago #

    Hey zzzmuzz,

    It could actually be related to the web server itself and not just PHP. If its the web server that is forcing the timeouts then your host will have to adjust that on their end.

    If you can give the developer version a try it has additional settings for faster database dumps and a network keep alive switch for some systems. The very latest version (0.5.0) can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues...

    Also be sure to check out the Archive file filters as they can help reduce the size of your package.

    Let me know if this solves your issue...

    Thanks

  5. zzzmuzz
    Member
    Posted 6 months ago #

    Thanks...but no it didn't even using the new version .

    Server Status: 500 -Internal Server Error
    Error Message:
    Request Timeout

    This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.

    I removed some tmp files, cache and some other old content. Vodahost won't change the timeout which is set to 60 seconds. They say it would impact server wide, so I have come to the end of that solution.

    I could try package creation again without some elements eg theme (Flexsqueeze) which I could recreate. What is your advice on which folders could be omitted.

    I have also tried xCloner but ran into similar issues. I have been working with Matt Garret's WP Simulator to use xammpp. I have already created Duplicator packages for other sites with very little in them and succeeded.

    Going to another host is a challenge as there are about a dozen sites to migrate (mind you, Cpanel to Cpanel should be easy. I would like to move to a NZ host, but if a host does not know about Duplicator, what are the key questions I should ask them first?

    I would love to get this sorted if possible. When Duplicator did the other sites the process was very smooth, but it looks like I might be near the end of the line on this one!

    Cheers,

  6. Cory Lamle
    Member
    Plugin Author

    Posted 6 months ago #

    Hey Zzzmuzz,

    If you run the scanner on step 2 of the latest version it will show you what items might be too large. Also if you have a large database then you could enable the mysqldump option from the settings page when creating the package, as this will also help when your installing as the mysqldump build is much faster than the PHP build method.

    If your going to use the exclusion filters the I would just exclude your wp-contents/uploads folder then manually FTP the files. If your still unable to get things going I have some resources that I have listed for alternatives to the Duplicator.

    Cheers~

  7. zzzmuzz
    Member
    Posted 6 months ago #

    WE wil get there one way or another!

    I installed the new version. The new tools etc look great and gave me a better idea of site size. I stripped out everything I reasonably could and ended up with site size of 124M

    But not able to create package due to timeout and possibly opendir on. Am checking with host again as they said it had been turned off.

    Tried mysqldump but plugin could not find it. I am checking with host to verify its location.

    Although changing to a new recommended host is possible, it is unlikely most users are going to want to go down this track for the sake of one (even if great and powerful) plugin. Also apart from the handful recommended, it is hard to know if the plugin will work with any other new host before doing the migration (and paying the $$!).

    The alternatives...eg backup buddy etc are not inexpensive options. I will also have another go at XCloner which MattG recommends.

  8. Cory Lamle
    Member
    Plugin Author

    Posted 6 months ago #

    Sounds good! Hope you get something to eventually work...

  9. zzzmuzz
    Member
    Posted 6 months ago #

    Just to get a final clarification on opendir.

    When using the scanning tool (new version) I get a:
    Warn - PHP Settings
    Open Base Dir : On

    I have contacted the host and they have sent me an image of their admin PHP panel. This clearly shows open_basedir ...off

    So which is correct?

    Or is the Scan message just a general info message?

  10. Cory Lamle
    Member
    Plugin Author

    Posted 6 months ago #

    Hey Zzzmuzz,

    Goto Duplicator > Settings > PHP Info and open up that section. Then search for 'open_basedir' that will show you the exact value that your PHP is using. Let me know what it says...

    Thanks~

  11. zzzmuzz
    Member
    Posted 6 months ago #

    It gives the path, and "No Value".

    /home/MYUSERNAME:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp

    How odd.

  12. Cory Lamle
    Member
    Plugin Author

    Posted 6 months ago #

    It will need the value false or 0 to pass...

  13. zzzmuzz
    Member
    Posted 6 months ago #

    Hmmm...ok. But what does this all mean? If the screen shot from Vodahost PHP admin panel shows "open_basedir ...off" but a false or 0 value does not show on Duplicator, is there some other setting which is required?

    Or is there an issue at the VH end. If so, what could that possibly be?

  14. Cory Lamle
    Member
    Plugin Author

    Posted 6 months ago #

    If it shows 'no value' then that should be ok. I think the issue is somewhere else on the host, possibly a permission somewhere that the plugin can't interpret. I would ask your host to help you find out where it is.

    Tell them the plugin works on hundreds of other hosts, and you can't figure out why it won't work on theirs. You are paying them a fee so they should do a better job of helping you diagnose the issue... You might have to look at the server error logs as well...

    Hope that helps...

  15. zzzmuzz
    Member
    Posted 5 months ago #

    I am still struggling on with the host on this. The latest is they say I can just take a Full backup or they will do a single site backup at their end.

    Just to be clear - a rather naive question- just how is Duplicator packages different to the Cpanel or host site backup?

  16. Cory Lamle
    Member
    Plugin Author

    Posted 5 months ago #

    The Duplicator also comes with an installer that allows for you to actually change the URL of the orginal WP website. So in order to migrate your site

    from: http://sitea.com
    to: http://siteb.com

    You have to manually scrub all the database data and some configuration files need to be updated. This is where the plugin comes in handy because it helps with the updating of this data. If your looking for just a backup solution, then the hosts backup files should be fine if you plan to restore it to the exact same domain name...

    Hope that helps!

  17. zzzmuzz
    Member
    Posted 5 months ago #

    Me again! My host (Vodahost) has changed settings as follows:
    "I have increased the maximum execution time to 5000"

    However, it still times out at about 2 minutes. Note that I emptied cache, error logs etc.
    Anything else you can think of which would give the Request Timeout error?
    Is there something the host is or may not be doing correctly at their end?
    I am in regular contact with the host about this.

  18. Cory Lamle
    Member
    Plugin Author

    Posted 5 months ago #

    Hey zzzmuzz,

    You can always try the developer line, I'm continually improving the performance there...

    You could also try this for Apache:

    <IfModule litespeed>
    RewriteRule .* – [E=noabort:1]
    </IfModule>

    You may also checkout this section on the FAQs I believe it may help with this issue:
    -> Browse to: http://lifeinthegrid.com/duplicator-faq
    -> Find section: "3. Troubleshoot=> Timeout Issues"

    Hope that helps!

Reply

You must log in to post.

About this Plugin

About this Topic