WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Duplicator not working correctly and no errors given (2 posts)

  1. Da9L
    Member
    Posted 4 months ago #

    Hello and thanks for a great plugin!

    I have recently moved to a new server, and since that i cannot use duplicator. I create a package from one server with duplicator, which i then copy over to the new server.. Running the installer.php doesnt give me any errors but the process is completed rather fast, and after its completion i notice that only a few files have been extracted, and no db entries have been created. I checked the install log from duplicator, which shows what seems to be read/write problems inside the folder, however i have given the root folder permissions of 777 so this should not be a problem.. I am quite blank at what to do here.. Can you guys assist?

    Heres where i get some error in the log in "Archive setup"

    ERROR: Unable to read from the extracted database.sql file .
    Validate the permissions and/or group-owner rights on directory '/var/www/vhosts/(blankedout)...'
    
    ERROR: Unable to create new sql file installer-data.sql.
    Validate the permissions and/or group-owner rights on directory '/var/www/vhosts/(blankedout)...' and file 'installer-data.sql'

    Since i have set chmod to 777 at this root folder i have no idea what might be causing this .. The archive is not damaged or anything as i've tried out the archive on the server which i copy it from under a new subdomain which works fine.

    Its by using the newest duplicator plugin version 0.5.1..

    https://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 4 months ago #

    Hey Da9L,

    You will want to update to 0.5.2 as it is the latest, also checkout this section on the FAQs I believe it may help with this issue:
    -> Browse to: http://lifeinthegrid.com/duplicator-faq
    -> Find section: "3. Troubleshoot=> Permission & System Issues"

    What you are probably missing is setting up the correct group/owner permissions with the command chown

    Hope that helps!

Reply

You must log in to post.

About this Plugin

About this Topic