WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Duplicator does not copy all files (10 posts)

  1. Mr Charlie
    Member
    Posted 1 year ago #

    Hi
    Here's a tricky problem. I have successfully used the Duplicator some time now, but after about 2 months ago it started to malfunction.
    I have a very strange problem. when I run duplicator I can not see the zip file and installer.php I have to download them via FTP.

    But! Duplicator does not anymore include all the files, The only files that are included in the zip are the following

    wp-content (folder) "chmod=0755"
    wp-includes (folder) "chmod=0755"
    database
    wp-comments-post.php "chmod=0644"
    wp-comments-rss2.php "chmod=0644"
    wp-config.php "chmod=0644"
    wp-feed.php "chmod=0644"
    wp-rss2.php "chmod=0644"
    xmlrpc.php "chmod=0644"

    The problem started a few month ago when I could not see the zip files. Now it donĀ“t work at all, There are no error codes
    I have reinstalled duplicator several times and also disabled other plugins without success
    Right now I have version 0.4.2 of the duplicator and wp 3.5.1, it does not help to go back to previous versions of duplicator, the problems are still the same.
    All the missing files has chmod 0644
    Does anyone recognize this problem and can advise me how to fix this?

    Thanks in advance

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Mr Charlie,

    Why don't you submit your log files via the support ticket system at support.lifeinthegrid.com and I'll have a look at them for you...

  3. Mr Charlie
    Member
    Posted 1 year ago #

    The problem is solved, it was max_execution_time that was the problem.

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds Good! Did you have to edit the php.ini directly or did you use another approach?

  5. Mr Charlie
    Member
    Posted 1 year ago #

    The problem persists, but i know what caused it. My host does not want to change in php.ini so it is not much I can do about it now, and it does not work to put it into htaccess for my host has some kind of barrier for max_execution_time in htacces.
    Hopefully it will work with a future version of Duplicator.

  6. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    If you want to add exclusion filters that might get your package down small enough to where the process won't timeout...

  7. Mr Charlie
    Member
    Posted 1 year ago #

    I've tried it but without success. Just for testing purposes, so I exluderade the plugins folder and then it worked as it should.
    A full zip file of my site is about 74 MB
    So there is no doubt that it's my host that is the problem. Because I have also tried a lot of backup plugin and none of them fully functional.

  8. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    You might try these settings as they will remove all the larger files types.

    - For file types click the [archive] link. It will add these file types (zip;rar;tar;gz;bz2;7z;) which are usually other backup and can be larger.

    - If the first one doesn't get your package small enough to process you might also add [wp-uploads] which you can then manually move your-self...

    - You could also get a host that doesn't perform those types of restrictions.

    Hope that helps!

  9. Mr Charlie
    Member
    Posted 1 year ago #

    Now the problems are definitely solved. I thought that maybe I can help someone else who ends up in the same situation. I was so confused by the timeout, etc. It had worked well before, and my webhost has not changed anything.
    My webhost did a maintenance on the shared server last night, my site has since problems started was slightly slower than usual, especially when in the admin menu.
    But after their maintenance so Duplicator works like a dream again.
    So the problem was simply that my hosting company had some problems with the speed.
    Thanks for a great plugin and a quick support +1

  10. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Mr. Charlie,

    Glad you got it going... Thanks for providing your update!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic