WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
Duplicate title with static homepage and blog page (7 posts)

  1. manelgarcia
    Member
    Posted 1 year ago #

    Hello,

    First of all, sorry for my bad english, it's not my native language but I expect to make me understand.

    Second, just congratulations for this perfect plugin for seo stuff, I've been using it for over 3 years, in all my projects.

    I just like to know if somebody is facing the same problem than me, and if it can be fixed.

    I have a static front page with a custom template, and another one called Blog with a default template.

    The problem is that the plugin is placing the same title in both pages.

    - I'd like to have at the homepage the seo settings in the AIO settings page I've set.
    - If not, at least, the AIO seo settings that I've set for each one of these pages.

    Any ideas?

    Btw, I'm using version: 2.0.2

    Thanks in advance!

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    manelgarcia,

    There will be some fixes and changes to the title code in the next release of the plugin; can you tell me which title it is using for both pages? Do you have the Home Title set in the All in One SEO Pack General Settings, and if so, is that the title that's coming up?

  3. manelgarcia
    Member
    Posted 1 year ago #

    I have:

    - Title and meta data set in AIO Settings pages (not fetching it)
    - Title and meta data set in 'Homepage' page (not fetching it)
    - Title and meta data set in 'Articles page' (using ig for the homepage aswell)

    What would be great is allways to use AIO general settings for main homepage metadata with no care of how am I building the homepage with static or not.

    I'll wait for an update or patch.

    Thanks!

  4. manelgarcia
    Member
    Posted 1 year ago #

    By saying ' (using ig for the homepage aswell) '

    I mean that AIOSP is using this meta data for both pages, which brings me to duplicate metas :\

    That is the main problem.

    Again, thanks in advance and congratulations for that excellent work

  5. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    manelgarcia,

    Thanks, I'll test this; could you also tell me what you have for all your settings under Settings -> Reading -> Front page displays in your WordPress Dashboard?

  6. manelgarcia
    Member
    Posted 1 year ago #

    Of course,

    I've set a Page called 'Homepage', and below for the posts pages another one called 'Blog'.

    I attach screenshot to clear, my english keep being so bad ;)

    http://postimg.org/image/glwue4pyf/

    Thanks!

  7. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    manelgarcia,

    Thank you! Yes, that all looks correct to me. This should be fixed in the next release, and if it isn't, I'll probably need your help in tracking down the specific issue you're experiencing.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.