WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] Dropdown menu's don't work when SlimStat is enabled (14 posts)

  1. TGBSeth
    Member
    Posted 1 year ago #

    I love SlimStat so far but once I began using it I noticed that all of my submenus\dropdown menus were no longer showing up.

    In order to make sure that it was SlimStat causing the issue, I deactivated all plugins and found that the problem was fixed.

    As I re-activated the plugins, the problem only returned when I activated SlimStat.

    Help?

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there

    Are you referring to the admin or front-facing site? Could you post the URL of the site where this is happening?

    Thanks

  3. TGBSeth
    Member
    Posted 1 year ago #

    Both, you can view it here http://www.tgbuzz.com

    The "News" and "Reviews" menu items should have dropdowns.

  4. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Okay, I see you're using a javascript minifier AND WP SuperCache, but you have Javascript Mode set to NO in WP SlimStat. Could you set that to YES, then clear WP SuperCache's cache and see how it goes? Also, is there a way to exclude WP SlimStat's javascript from being included into the minified code? That JavaScript is already minified, and I'm afraid that the plugin you're using to minify it again breaks the code. You may want to talk to the developers to see if they can help you...

    Camu

    PS: a vote for my plugin (and saying that our plugin is not broken) would be a nice way to say thank you.

  5. TGBSeth
    Member
    Posted 1 year ago #

    It is active, I'm using it right now. The menus aren't appearing because I have slimstat enabled.

  6. camu
    Member
    Plugin Author

    Posted 1 year ago #

    See my edited message here above. Also, I just let JSLint parse the code at

    http://www.tgbuzz.com/wp-content/cache/autoptimize/autoptimize_ca474b930fb2f60343f89d5f66969b1e.php

    and I got a bunch of errors, meaning that something is not right with the minifier...

    Camu

  7. TGBSeth
    Member
    Posted 1 year ago #

    Should I disable it then?

  8. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Well, some of these minifiers provide ways to exclude one or more Javascript. I'm not familiar with the one you're using, sorry.

    Camu

  9. TGBSeth
    Member
    Posted 1 year ago #

    That's fine, I disabled it and now the menus show up while slimstat is active.

    I'll just keep the minifier off, I'd rather have SlimnStat than have the minifier active haha.

    By the way, awesome job with SlimStat it is easily the best analytics service I've used so far!

  10. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Actually, looks like someone else had had the same problem already, but apparently the name of your plugin didn't ring a bell right away ;)

    http://wordpress.org/support/topic/confict-with-wp-slimstat-plugin?replies=6

    There you go!

    Don't forget to vote!

  11. futtta
    Member
    Posted 1 year ago #

    TGBSeth; you can indeed exclude slimstat from being aggregated, minified & moved to the end of the HTML in Autoptimize's admin screen, thus keeping both JS-optimization and slimstat.

    Camu; js-errors not withstanding, does Slimstat have problems with being aggregated with other JS and being moved to the bottom of the HTML?

  12. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Futtta,

    I'm not sure what the problem could be. The Javascript I use is already supposed to stay at the bottom of the HTML. In TGB's case, the error I saw was thrown by the javascript attached right after mine.

    You can find my Javascript at

    http://plugins.svn.wordpress.org/wp-slimstat/trunk/wp-slimstat.js

    Could it be because of the missing semi-colon at the end of the code? If you have any insights that can point me into the right direction, I'm more than happy to update my code to make it compatible with Autoptimize.

    Thanks, Futtta.

    Camu

  13. futtta
    Member
    Posted 1 year ago #

    If you have any insights that can point me into the right direction, I'm more than happy to update my code to make it compatible

    Same here :-)

    I've installed slimstat on my test-blog with Autoptimize enabled and all seems well. Must be a pretty specific combination of theme and/or plugin + slimstat + autoptimize that triggers this javascript-error, which makes this pretty hard to debug.

    The semi-colon won't make things worse and just might help, so if you could do that?

  14. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Done. BTW same here for my tests. I installed Autoptimize and all seemed to work flawlessly, so I'm not sure what triggers the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.