WordPress.org

Ready to get started?Download WordPress

Forums

Dropdown menu delay problem? (2 posts)

  1. guguwpblog
    Member
    Posted 3 years ago #

    hii all

    in my wordpress theme when i go to a page, the dropdown menu takes little time to come. there is a delay in dropdown menu. i am making website using xampp. i hope its not because of local server. my header php is

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
    		<head profile="http://gmpg.org/xfn/11">
    		<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    		<title><?php wp_title('«', true, 'right'); ?><?php bloginfo('name'); ?></title>
    
    		<link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/reset.css" type="text/css" media="screen" />
    		<link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/general.css" type="text/css" media="screen" />
    		<link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/<?php if( get_option(SHORTNAME."_color") != '') { echo get_option(SHORTNAME."_color"); } else {?>orange<?php } ?>/colors.css" type="text/css" media="screen" />
            <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    
    		<link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/js/prettyPhoto/css/prettyPhoto.css" type="text/css" media="screen" />
         <!--[if lte IE 7]>
        <link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo('template_directory'); ?>/css/ie7.css"/><![endif]-->
    	<!--[if lt IE 7]>
     	<script src="<?php bloginfo('template_directory'); ?>/js/DD_belatedPNG_0.0.8a-min.js"></script>
    	<script>DD_belatedPNG.fix('.logo img, .page_title .bold .slide_button, .learnmore, .learnmore span, .theme_button, .footer_widgets .col2 li ');</script>
    	<link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo('template_directory'); ?>/css/ie6.css"/><![endif]-->
    		<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    		<?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    		<?php wp_head(); ?>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/cufon/cufon-yui.js"></script>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/cufon/Vegur_300-Vegur_700.font.js"></script>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/superfish/hoverIntent.js"></script>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/cycle/jquery.cycle.all.min.js"></script>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/superfish/superfish.js"></script>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/prettyPhoto/js/jquery.prettyPhoto.js"></script>
    		<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/theme.js"></script>
    		</head>
    <body <?php body_class(); ?>>
        <div class="wrapper">
            <div class="header">
                <div class="wrap">
                	<div class="logo">
    					<?php if ( is_front_page() ) { ?>
                        <h1><?php if( get_option(SHORTNAME."_logourl") != '') { ?><a href="<?php echo get_option('home'); ?>"><?php if( get_option(SHORTNAME."_logodisable") != '') {   } else { ?><img src="<?php echo get_option(SHORTNAME."_logourl"); ?>" /><?php } ?><span><?php bloginfo('name'); ?></span></a><?php } else{ ?><a href="<?php echo get_option('home'); ?>/"><?php if( get_option(SHORTNAME."_logodisable") != '') {   } else { ?><img src="<?php bloginfo('stylesheet_directory'); ?>/img/logo.png" alt="<?php bloginfo('name'); ?>" title="<?php bloginfo('name'); ?>" width="80" height="80" /><?php } ?><span><?php bloginfo('name'); ?></span></a><?php } ?></h1>
    					<?php } else { ?>
    					<?php if(get_option(SHORTNAME."_logourl") != '') { ?><a href="<?php echo get_option('home'); ?>"><?php if( get_option(SHORTNAME."_logodisable") != '') {   } else { ?><img src="<?php echo get_option(SHORTNAME."_logourl"); ?>" /><?php } ?><span><?php bloginfo('name'); ?></span></a><?php }else{ ?><a href="<?php echo get_option('home'); ?>/"><?php if( get_option(SHORTNAME."_logodisable") != '') {   } else { ?><img src="<?php bloginfo('stylesheet_directory'); ?>/img/logo.png" alt="<?php bloginfo('name'); ?>" title="<?php bloginfo('name'); ?>" width="80" height="80" /><?php } ?><span><?php bloginfo('name'); ?></span></a><?php } ?>
    					<?php } ?>
                    </div>
                    <?php
    					if ( get_option(SHORTNAME."_mainnavhome") != ''){ $theme_mainnav = 'show_home=' . get_option(SHORTNAME."_mainnavhome"); } else {$theme_mainnav = 'show_home=1';}
    					if( get_option(SHORTNAME."_mainnav") != '') {$theme_mainnav .= '&sort_column=menu_order&include=' . get_option(SHORTNAME."_mainnav"); wp_page_menu($prosto_mainnav);} else {wp_page_menu();}
    				?>
    			</div>
    		</div>

    Please help me to sort out this thing. tell me how can i get rid of that delay time so that dropdown menu come without any time delay.

    Thanks for reading/considering

  2. Flex Perception
    Member
    Posted 3 years ago #

    I would recommend starting from scratch if you haven't done much work on the site. Never seen anything like that happen, but it probably has something to do with your menus and your functions.php file. Maybe try reverting your functions.php to the same as a fresh install?

Topic Closed

This topic has been closed to new replies.

About this Topic