WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Drop down menus not working in WP3.5 RC 6 (5 posts)

  1. Robert Dall
    Member
    Posted 1 year ago #

    I have been playing around with WordPress 3.5 RC5 and now RC6 on a localhost while I dev a new project and I found an odd bug. But I can't replicate it on a live sever so I don't want to submit a bug report. So I am placing it here:

    My drop down menus work in my localhost using 3.4.2 but when I switch over to 3.5RC6 the drop down fail. See screenshot http://cl.ly/image/2J0D2w251722 But then when I install the same version of WP and upload the same dev the menu's work? See screenshot http://cl.ly/image/2t0H090a121y

    I am guessing there are some setting that have changed between my mamp localhost and my server… But you got me as to what and to how to check?

    I am no systems admin, I am just really handy with CSS and know my way around a WordPress template.

  2. curtismchale
    Member
    Posted 1 year ago #

    Are your styles enqueued properly or are you using the plain old styles.css file?

    Are you using any type of javascript dropdown stuff, like superfish?

  3. Robert Dall
    Member
    Posted 1 year ago #

    I am using a plain old styles.css file and it was working on previous WordPress versions.

    The Theme started out as a Bluelime Media HTML5 vanilla theme and was working with other wordpress versions.

    Here is the link… to my local version http://24.207.105.120:8888/dal/

    But yet the same theme with the same version of WordPress works perfectly fine on my site5 hosted server:

    http://dal.32spokes.com/

    No javascript drop down stuff that I know about… 

  4. If you look at the source code, the sub menu now has the class sub-menu.
    In your CSS you have .children.

    I think that you need to change:

    #top-nav ul ul.children

    to #top-nav ul ul.sub-menu or better still

    #top-nav ul ul

  5. Robert Dall
    Member
    Posted 1 year ago #

    Ok Thanks Curtis and Christine… 

    Confused I was… Solved this is…

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.