WordPress.org

Ready to get started?Download WordPress

Forums

Drop down menu not working: Brunelleschi (5 posts)

  1. Kitty Blake
    Member
    Posted 1 year ago #

    I am trying to create a drop-down menu.
    I make new menu in appearance>menus the top level items appear, but no sub-headers.
    I tried disabling all my plug-ins, but no luck.
    Any ideas much appreciated.

    http://teaatthree.co.uk

    ps. apologies for posting on existing topic and thanks to member for reminding me of etiquette:)

  2. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    Does that theme come with a section in the dashboard named something similar to, "Custom CSS" or "Custom Styles", or are you working on a Child Theme of Brunelleschi?

  3. Kitty Blake
    Member
    Posted 1 year ago #

    There are two options on dashboard menu appearance>themes, under theme is customize, which allows you to select custom menus.

    Also is brunelleschi options, which gives various choices, centering header etc..

    I am new to WP, so this site was by way of learning. I have been tinkering a bit with the CSS so may have inadvertently affected the menu.

  4. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    Ideally you should be working in a Child Theme of Brunelleschi, so you can deactive the Child Theme (and activate Brunelleschi back) to see whether the problem persists. Alternatively you could be adding CSS changes to a Custom CSS Manager plugin, where you could deactivate the plugin to see whether the problem persists.

    Remember when you're modifying themes' files, your changes will erase once the themes update. This is one emphasis on using a Child Theme or Custom CSS plugin.

    The CSS you need, to make the dropdown visible, is something like;

    ul li:hover ul {
     display: block;
    }
  5. Kitty Blake
    Member
    Posted 1 year ago #

    Yes, if I'd made child theme that would have saved a lot of head scratching.

    Thanks for CSS snippet, it is already in stylesheet, so not sure where problem lies. I have tried a few other things, but no joy.

    I guess I'll just live with it for now and when I have more time I will start from scratch with child theme. At least I have learned a good lesson;)

    Thanks for your help and advice, I really appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic