WordPress.org

Ready to get started?Download WordPress

Forums

Download Monitor
[resolved] Downloading 0 bytes on v1.3.2 (8 posts)

  1. mampoerboer
    Member
    Posted 9 months ago #

    After updating to version 1.3.2 the downloads are 0 bytes. It sees the download from the shortcode, but when I click "download" it downloads the file as 0 bytes.

    http://wordpress.org/plugins/download-monitor/

  2. mikejolley
    Member
    Plugin Author

    Posted 9 months ago #

    From which version? Server software? (windows v linux) PHP version? etc etc

  3. mampoerboer
    Member
    Posted 9 months ago #

    Apache version 2.2.21
    PHP version 5.2.17
    MySQL version 5.0.96-community
    Architecture x86_64
    Operating system linux

  4. mikejolley
    Member
    Plugin Author

    Posted 9 months ago #

    Could you perhaps see which one of these changes affects it?

    https://github.com/mikejolley/download-monitor/commit/70d478b0f4218b3e675b42e76cb0906e282d606c

    My downloads are working, so it must be related to environment.

  5. mampoerboer
    Member
    Posted 9 months ago #

    Sorry Mike, I wouldn't even know where to start. I've just done HTML, no idea about php or java.

  6. mikejolley
    Member
    Plugin Author

    Posted 9 months ago #

    In the includes/class-dlm-download-handler.php file, compare to the link I send. Green is whats new, red is removed (from the last version).

    Try changing:

    @ob_clean(); // Clear the output buffer

    Back to:

    while ( ob_get_level() > 0 ) @ob_end_clean();

    I don't know why this would break, but that would be my guess.

  7. mampoerboer
    Member
    Posted 9 months ago #

    Hi Mike,

    The issue lies with - WordPress HTTPS (SSL) - plugin. When this plugin is activated, the download gives 0 bytes. If I deactivate it, it works fine with the current version.

    The plugin is also not working with my theme so gonna get rid of it but you might want to look into why this is happening.

    Thanks a mill for the help. Great plugin by the way :)

  8. fantapop
    Member
    Posted 6 months ago #

    Mike,

    Making that change you suggested fixed the problem for me.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.