WordPress.org

Ready to get started?Download WordPress

Forums

WP-Filebase Download Manager
[closed] Download Files Problem (11 posts)

  1. tondieu
    Member
    Posted 1 year ago #

    Hello Fabian,

    I use your plugin for develop a download website.
    It works great with small files (10mb or less), but when they are more bigger than 50mb, they don't download entire. It's common start with a really good connection, but past 1 minute or similar, the file "it's downloaded", but isn't the entire file (like 15% of the real size).

    I don't know if this can be controlled with the plugin or if I have to ask about that to my host manager, because I don't understand well what happens. Can you help me with this?

    Thank you so much.
    Have a nice one.
    Ed.

    http://wordpress.org/extend/plugins/wp-filebase/

  2. gokul84
    Member
    Posted 1 year ago #

    i too have the same problem , waiting for authors answer.

  3. Fabian
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    Is PHP Safe Mode enabled? If you are not sure ask your hosting provider about increasing PHP's max_execution_time, which is set in php.ini.

  4. gbj
    Member
    Posted 1 year ago #

    I got the exact same issue.

    Isn't the max_execution_time used primary for uploads?

    I host several large files for android developers, so it's a bit frustrating when the users complaint about broken downloads. I Primary happens with users that has slow connections, any points would be greatly appreciated.

  5. gbj
    Member
    Posted 1 year ago #

    If you are using mod-fcgid it's probably related to that. Since every download is served as a php process.
    Is it possible to serve the downloads another way?
    Since having 50-75 concurrent downloads will kind if use 6-8GB of memory.

  6. illbehonest
    Member
    Posted 1 year ago #

    Many of my users have been having the same issue. iTunes and RSS podcast mp3's cannot be downloaded, only listened to, and some times you only get 15% of the hour long message rather than the full thing. Is there any solution? Did the max-execution time mentioned above work?

  7. Fabian
    Member
    Plugin Author

    Posted 1 year ago #

    Try the following:
    Edit classes/Download.php by adding the line:

    <?php
    @ini_set("zlib.output_compression", "Off");
    class WPFB_Download {
  8. gbj
    Member
    Posted 1 year ago #

    Hi fabifott,

    Are you referring to both of us?

  9. illbehonest
    Member
    Posted 1 year ago #

    I added the above code, but what was it suppose to specifically fix? I'm trying to test to see what change has been made and corrected.

    I also did a test by having a direct URL in the podcast, and iPhones were able to download the iTunes/RSS feed MP3. But when it's got the /download/ in the url to the mp3, it doesn't work. I tried messing with WpFileBase > Downloads options, but couldn't seem to make it show a direct link to where the mp3 is located.

    Thanks you for your time.

  10. Dediux
    Member
    Posted 4 months ago #

    We are experiencing the same problem, tried all that's in this thread, but nothing has changed...

  11. esmi
    Theme Diva & Forum Moderator
    Posted 4 months ago #

    @Dediux: If you require assistance then, as per the Forum Welcome, please post your own topic. This topic references a pretty old version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic