WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Download failed.: Could not create Temporary file (29 posts)

  1. SomeGuy62789
    Member
    Posted 5 years ago #

    Ok, trying to do an automatic upgrade from 2.7 to 2.7.1 and after logging in it says:

    "Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Download failed.: Could not create Temporary file

    Installation Failed"

    Um, a little help please.

  2. Samuel B
    moderator
    Posted 5 years ago #

    you may need to manually create an upgrade folder in /wp-content

  3. SomeGuy62789
    Member
    Posted 5 years ago #

    Nope, that didn't work.

  4. WordPress Hosting
    Member
    Posted 5 years ago #

    the issue is your wordpress working directory permission related. if you're using IIS server, make sure to grant "network" this user "RWX" permissions and propagated to all subdirectories. that should fix it.

  5. sarahwood3587
    Member
    Posted 5 years ago #

    I'm having the same problem, and manually creating an "upgrade" folder didn't work for me either.

  6. SomeGuy62789
    Member
    Posted 5 years ago #

    Thanks, lzjimmy. That fixed it for me.

  7. rhagl
    Member
    Posted 5 years ago #

    I did a chmod 777 on the wp-content directory (through filezilla, non-recursive) while upgrading. That worked. Afterwards I set it back to 755

  8. leachsquad
    Member
    Posted 5 years ago #

    I am using IIS server, but not sure how to grant "network" this user "RWX" permissions and propagated to all subdirectories.

    Can you help?

  9. karl19
    Member
    Posted 5 years ago #

    Hi there,

    If your site is online and you've got access to your controlpanel, you can usually use a FileDirectory function to navigate through your website structure. You need to change the permission settings for the wp-content folder. Now, on a Unix server this is really simple, you can do it via FTP, but on Windows, it's done differently.. annoying, but some say it's safer - that's another debate.

    If you navigate to your wp-content folder and get the permissions panel up, you'd need to allow access to users visiting your site. I'm not very good with server configurations, but our host has a site user and a network user: we set the file permissions to read/write for the site user. Save and you're good to go.

    If you don't know how to get to the above, just asking your hosting company to tell you how to access file permissions for you site's folders and what the site user is called, should do the trick.

    Good luck!

  10. jamesisin
    Member
    Posted 5 years ago #

    karl19 - When you say "site user" do you mean the "IIS_WPG" account or the "Internet Guest Account" or perhaps some other account?

  11. invi2003
    Member
    Posted 5 years ago #

    Ok here's how i got it working.

    I have my own dedicated server with just one site. It can get tiresome changing folders permissions from 755 to 777. After doing some research I noticed that Apache is running with <strnong>php safe mode "On"</strnong>

    Once i changed it to Off i was able to install/update plugins with the wp-content folder having a 755 permission.

    I know that having Safe mode off is a security issue but being that i have my own server and only me as the only user i don't have a problem with it.

    Note: If you have share hosting, you will have to talk to them to see what can be done about this but I bet there's some other way to turn it off for just your site.

  12. karl19
    Member
    Posted 5 years ago #

    @jamesisin,

    sorry, not 100% sure, different hosts call it different things (and I'm not very good with IIS, just have to build sites on it sometimes) - best would be to check with your host.

  13. jamesisin
    Member
    Posted 5 years ago #

    karl19 - Well, that would be me.

  14. bigsquaredot
    Member
    Posted 5 years ago #

    @invi2003 Thank you so much. That worked perfectly on my (dv) server with Media Temple.

  15. johnwar
    Member
    Posted 5 years ago #

    Thanks all, just get done mine. Almost manual it :-)

  16. torlang
    Member
    Posted 5 years ago #

    I generally don't like to leave the wp-content folder in 777, so I usually change it back to 775 when I get done upgradeing all my plugins.

  17. schindyguy
    Member
    Posted 5 years ago #

    Its the 755 permission thing that worked for me.

    Just temp change it 777 while upgrading plugins or wordpress.

    And the safe mode issue will solve it too.

  18. Daniel Craig Jallits
    Member
    Posted 4 years ago #

    Quick ammendment to the post for users on Media Temple's DV servers. There is a risk to this technique as this kills safe_mode for the site..

    WP-CONFIG should contain the following:

    define('FS_CHMOD_FILE', 0755);
    define('FS_CHMOD_DIR', 0755);
    define('FS_METHOD', 'ftpext');
    define('FTP_BASE', '/httpdocs/');
    define('FTP_CONTENT_DIR', '/httpdocs/wp-content/');
    define('FTP_PLUGIN_DIR ', '/httpdocs/wp-content/plugins/');
    define('FTP_USER', 'USERNAME');
    define('FTP_PASS', 'PASSWORD');
    define('FTP_HOST', 'SERVER:PORT');

    HTACCESS should contain the following:
    php_value safe_mode "1"

  19. alynastan
    Member
    Posted 4 years ago #

    I did the same thing, but I used Total Commander to do it. Super simple and it worked like a charm.
    Thanks guys!

  20. acekin
    Member
    Posted 4 years ago #

    I have a similar problem. Plugin install or update tries to write the temporary file it downloads to the root directory. I have no way of changing permissions in the root, ISP won't allow it. I have about a dozon other WordPress installations none has this problem. Is there a way to designate a temporary directory and force everything to go there? I can assign, and have assigned, RWX permissions in wp-content.

    Thanks.

  21. acekin
    Member
    Posted 4 years ago #

  22. acekin
    Member
    Posted 4 years ago #

    @jallits

    In the code snippet you provide for servers running Apache or will it work for IIS? On IIS I don't believe there is .htaccess file, is that required? Is there a down side to using this snippet in the wp-config file?

    I am still searching for a solution that works universally on different IIS servers and for WP and plugin updates.

  23. davidmartinstudios
    Member
    Posted 4 years ago #

    Un-checking the "php safe-mode on" box to turn safe-mode off worked for me.

    I found this helpful: http://wp.shantopagla.com/2009/wordpress-download-failed-could-not-create-temporary-file/

  24. jimmygilmore
    Member
    Posted 4 years ago #

    Karl 19, Thanks. Kept looking for network file but it was the wp-content file that needed permissions changed.

  25. misterm2009
    Member
    Posted 4 years ago #

    I run a dedicated server with 1and1 and had the problem above. Sure enough, I had left PHP safe mode on in Plesk. I disabled safe mode and the problem went away.

  26. GuruMeister
    Member
    Posted 4 years ago #

    On Linux/Unix installation suPHP is enabled by default.. The root cause of this and many other upgrade / permission issues is in running php mode as Apache .. try running PHP as another user and surely this saga will end.

    G.

  27. trusktr
    Member
    Posted 4 years ago #

    turning PHP Safe Mod 'off' worked for me!

    Just turn php safemode off and you can leave your chmod at 755

  28. doraloen
    Member
    Posted 4 years ago #

    I'm a novice in this, and I want to turn of php safe mode, but where do i do that?

  29. donnie1967
    Member
    Posted 4 years ago #

    Exactly, how DO you turn php safe mode off?

Topic Closed

This topic has been closed to new replies.

About this Topic