WordPress.org

Ready to get started?Download WordPress

Forums

Download failed. A valid URL was not provided. (11 posts)

  1. mayday
    Member
    Posted 2 years ago #

    A fresh install of WP 3.3.1 in a subdirectory, /novus, of mysite.com (for example). I get this error when trying to install a standard theme:

    Downloading install package from /var/www/vhosts/mysite.com/httpdocs/novus/assets/theme.zip…

    Download failed. A valid URL was not provided.

    Otherwise, I can create new posts and pages and browse the site. I can upload manually and all is working. Same error message for plugins.

    Any thoughts?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Can you install the theme manually using FTP?

  3. mayday
    Member
    Posted 2 years ago #

    Yes I can install themes and plugins manually and they work fine. It is just the Search install and upload methods that generate that error.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    This could be a server configuration issue. Have you checked your server's error logs? Have you spoken to your hosts?

  5. mayday
    Member
    Posted 2 years ago #

    I have not looked into this. I have a dv server from MT and am running 8 different WP sites, all with no problems.

    Something is not set right. I have looked at permissions for novus/wp-content/themes and plugins and uploads, setting them to 777 equivalent. I have looked at settings and confige.php and .htaccess. Where else to look?

  6. blakemiller
    Member
    Posted 2 years ago #

    I just upgraded a blog to 3.3.1 and getting the exact same errors on both Themes and Widgets. I too can install things manually, but not automatically. I have a few dozen other WP installs on these servers, so it's gotta be something in 3.3.1 since this is my first install of it.

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    @blakemiller: It is considered impolite to interrupt another poster's thread. Please post your own topic.

  8. mayday
    Member
    Posted 2 years ago #

    If someone could provide a clue to why this is happening it would help more than just me.

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you checked your server's error logs? Have you spoken to your hosts?

  10. razormicro
    Member
    Posted 2 years ago #

    I had the same but have figured it out as it applies to my server configuration on Linux running Plesk CP. Hopefully by sharing this helps someone else out.

    2 Steps required.

    1) If you are using Plesk Control Panel then in Setup >> look under Services for: PHP Support - make sure (PHP 'safe' mode on is UNCHECKED)

    2) In WordPress Dashboard go to Settings >> Permalinks - Select your Common Settings preference and click Save Changes button. You will then see the following message:
    "If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all."

    Underneath is a block of code that you need to save and create an .htaccess file (save this text file as .htaccess). Then upload this to your Root of your Web Hosting server via FTP.

    That should do the trick.

  11. tung148
    Member
    Posted 2 years ago #

    I also have a dv server from MT. To fix this problem just enable fastcgi on your site.

    http://kb.mediatemple.net/questions/1890/%28dv%29+How+do+I+enable+FastCGI%3F#dv_40

Topic Closed

This topic has been closed to new replies.

About this Topic