WordPress.org

Ready to get started?Download WordPress

Forums

Double titles in RSS feed. HELP!!! (19 posts)

  1. preservingyork
    Member
    Posted 2 years ago #

    I'm having issues with double titles in my RSS feed. The title appears as:

    Preserving YorkPreserving York

    I've looked through the settings and do not see a way to correct thins. If it a WordPress issue, a theme issue, or some other issue?

  2. Altaf Hussain Patel
    Member
    Posted 2 years ago #

    <li>
    <a href="<?php bloginfo('rss2_url'); ?>" title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?></a>
    </li>

    look through this in your coding if it's double remove one for the title :) better to see the documentation

    Documenation Link For Rss Feed

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  4. preservingyork
    Member
    Posted 2 years ago #

    Esmi, are there specific types of plugins than can cause issues? I was also curious if using Feedburner could cause any issues.

    Deactivating plugins now.

  5. preservingyork
    Member
    Posted 2 years ago #

    I deactivated ALL plugins and the results were the same. I changed to the Twenty Eleven theme but the results were also the same. If you go to the URL of my feed (www.preservingyork.com/feed) you can see the problem in the TITLE tag.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Can we see the site with all plugins deactivated please?

  7. preservingyork
    Member
    Posted 2 years ago #

    All plugins are now currently deactivated.

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Sorry but you're using Weaver. You need to switch to the original, unedited, Twenty Eleven theme.

  9. preservingyork
    Member
    Posted 2 years ago #

    Sorry about that. Theme is now Twenty Eleven.

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    ...and the double title in your RSS feed has now vanished.

    So it looks like a problem within the Weaver theme. As this is fairly complex theme with many of its own setting, try posting on the theme's dedicated forum: http://wpweaver.info/forum/ It might be worth referencing this thread just to prove that you have gone through all of the basic troubleshooting steps already.

  11. preservingyork
    Member
    Posted 2 years ago #

    Thanks so much. I'm guess when I looked I should have cleared my cache, as I was still seeing the double titles.

  12. esmi
    Forum Moderator
    Posted 2 years ago #

    It's always worth pressing CTRL and F5 simultaneously (aka "a hard refresh") when viewing an updated page/site. :-)

  13. preservingyork
    Member
    Posted 2 years ago #

    Thanks esmi. I posted to the Weaver forum, so I'm hoping to find a solution. In addition to the problem I mentioned previously, when I look at the coding of my feed in IE9 and Firefox, it shows:

    <title>Preserving York</title>

    ...but if I look in Chrome, it shows:

    <title>Preserving YorkPreserving York</title>

    Odd indeed.

    Regardless, thanks for helping pinpoint the theme as the culprit.

  14. preservingyork
    Member
    Posted 2 years ago #

    After corresponding with some Weaver folks, I was told that theme has nothing to do with feeds, and the problem is WordPress related. So, where do I go from here?

    Could someone please look at my feed in Google Reader, which should have the double blog title shown.

  15. preservingyork
    Member
    Posted 2 years ago #

    Someone pointed out that my home page markup may be causing the problem:

    <h1 id="site-title"><span><a href="http://www.preservingyork.com/" title="Preserving York" rel="home">Preserving York</a></span></h1>

    This person said "both the anchor text and the link title are identical. Likely they are getting stitched together".

    The CSS in header.php is shown like this:

    <h1 id="site-title"<?php echo weaverii_hide_site_title();?>><span><a>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>" rel="home"<?php weaverii_hide_site_title();?>><?php echo $title; ?></a></span></h1>

    Thoughts?

  16. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Only it doesn't say that. It reads,
    <h1 id="site-title"><span><a href="http://www.preservingyork.com/" rel="home">Preserving York</a></span></h1>

    The title="Preserving York" is not there.

    I run weaver-ii-pro and I compared the source code. Are you using Weaver as SEO? If so, check the SEO tags there and make sure you don't have a title there. Weaver should pick that up from WordPress settings, general.

  17. preservingyork
    Member
    Posted 2 years ago #

    This is shown in the SEO settings within Weaver. There were already there and were not edited by me:

    <meta name="description" content=" Preserving York - Family. Heritage. History. Genealogy. Memories. Tradition. Life. " />
    <meta name="keywords" content="Preserving York blog, Preserving York" />

    Should I change anything about this?

  18. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    I think that looks ok.

  19. newblogtalk
    Member
    Posted 1 year ago #

    I had the same issue and found out a easy way to resolve this issue.

    1. Go to Feedburner and click on the Feed Title.

    2. Click the Optimize tab.

    3. Click “Title/Description Burner” on the lower left.

    4. Enter your site title and click “Activate

Topic Closed

This topic has been closed to new replies.

About this Topic