WordPress.org

Ready to get started?Download WordPress

Forums

double title (4 posts)

  1. duciwish
    Member
    Posted 1 year ago #

    I'm not sure if this is a plugin or theme issue. I have a double title. I only put bankruptcy records once and it shows it twice. I haven't entered any title stuff on either seo plugin. I've read some suggest not using both plugins, but I'd like to use both. I've heard of many sites having more than one seo plugin and not having title issues. thanks

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
    <html lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#">
        <head>
            <meta charset="UTF-8" />
            <title>
                Home Page | Bankruptcy RecordsBankruptcy Records        </title>
            <link rel="profile" href="http://gmpg.org/xfn/11" />
            <link rel="pingback" href="http://us-bankruptcy-records.com/xmlrpc.php" />
            <link rel="stylesheet" type="text/css" media="all" href="https://us-bankruptcy-records.com/wp-content/themes/squirrel/style.css" />
            <script type='text/javascript' src='https://us-bankruptcy-records.com/wp-includes/js/comment-reply.min.js?ver=3.5.1'></script>
    
    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.3.4.4 - http://yoast.com/wordpress/seo/ -->
    <title>Home Page - Bankruptcy Records</title>
  2. Tara
    Member
    Posted 1 year ago #

    Try this and see if it works:

    Go To Dashboard > Settings > General

    You will end up on the General Settings Page

    The top field on that page should be "Site Title" whatever is entered there is probably the same text you are seeing posted twice in the page title.

    Delete whatever you have typed in "Site Title"

  3. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    for testing, disable the yoast seo plugin to see if the double title disappears;

    if it does, you might need to simplyfy the meta title code of your theme;
    re-activate the seo plugin again;

    replace this section in header.php:

    <title>
                <?php
                /*
                 * Print the <title> tag based on what is being viewed.
                 */
                global $page, $paged;
                wp_title('|', true, 'right');
    // Add the blog name.
                bloginfo('name');
    // Add the blog description for the home/front page.
                $site_description = get_bloginfo('description', 'display');
                if ($site_description && ( is_home() || is_front_page() ))
                    echo " | $site_description";
    // Add a page number if necessary:
                if ($paged >= 2 || $page >= 2)
                    echo ' | ' . sprintf(__('Page %s', 'squirrel'), max($paged, $page));
                ?>
            </title>

    with just:

    <title><?php wp_title(); ?></title>

    this should allow the plugin to have the full control over the meta title.

  4. duciwish
    Member
    Posted 1 year ago #

    I deactived yoast plugin. However, it didn't change the results for double title. Therefore, I didn't change the header code.
    I noticed that the general settings and my theme customize title sections are the same titles. Is this normal?

Topic Closed

This topic has been closed to new replies.

About this Topic