WordPress.org

Ready to get started?Download WordPress

Forums

Double paragraph enclosing (5 posts)

  1. Tommes
    Member
    Posted 9 years ago #

    Hi there,

    since I updated my local wordpress installation to 1.5 it produces invalid HTML.

    All paragraphs of Posts are double enclosed by <p> so it looks like this:

    <!-- The content -->
    <p><p>blah...</p></p>

    Any idea how to fix this annoying problem?

    Tommes

  2. Lorelle
    Member
    Posted 9 years ago #

    Did you run the "upgrade.php" as part of your install? I don't know if this is the problem, but it can make weird things happen.

    Do you put your code in HTML when you post it? And on the Admin Panel > Options > Writing, do you have "WordPress should correct invalidly nested XHTML automatically" turned on or off. This might help us narrow this down a little.

  3. Tommes
    Member
    Posted 9 years ago #

    Yes, I run the update.php.

    But disabling the XHTML correction nor enclosing my posts in html tags takes effect.

    Don't you have this phenomen with your installation?

  4. Lorelle
    Member
    Posted 9 years ago #

    Never, and I've done a few of them. So the XHTML doesn't do anything one way or the other (which it really only does when you have it running and then make a post. It won't change old posts, I think). So you turned on XHTML correction and made a post and it is still doubling....hmmm.

    And you have no html <p> in your post, it's just plain text with no html? Hmmmm.

    I hope someone can jump in here with an answer. I'm stuck on this one.

  5. Tommes
    Member
    Posted 9 years ago #

    However, thank you for your answers. I fixed the problem by a new installation ( not an upgrade ). Now wordpress returns vaild xhtml apart from german special chars like Ü, Ö, Ä and ß.But this is an other story :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.