WordPress.org

Ready to get started?Download WordPress

Forums

Double page names (12 posts)

  1. danielfontaine176
    Member
    Posted 2 years ago #

    My site danielsfontaine.com is on the twenty eleven theme.

    I recently changed my blog title from Inside the mind ( which I didn't like ) but when I was creating it I felt I had to put something.

    While chatting with someone on G+ the said just make it your url name if you are looking to brand yourself. So I did.

    Today I Site:danielsfontaine.com to see how things are doing with google and noticed all my links have the url in the page name twice.

    I have looked around and not being a code guy can't figure where it is originating from. For Plug ins I use

    Word Press SEO
    Google Webmaster tools
    Askimet
    Adsense Made Easy
    Google XML sitemaps
    Jetpack
    Sharebar
    Simple FB connect
    WP touch

    I did search here and google before posting and didn't find anything that was an
    " a ha! " moment so I figure I would ask. Any feedback or thoughts would be appreciated.

    Thanks,

    Dan

  2. danielfontaine176
    Member
    Posted 2 years ago #

    Can anyone point me in the right direction on this? I spent a few hours today trying to determine why this is happening to now avail. Any thoughts or feedback would be greatly appreciated.

    Thanks!

  3. Big Bagel
    Member
    Posted 2 years ago #

    The <title> tags for all your posts/pages look similar to this:

    <title>G+ | danielsfontaine.comdanielsfontaine.com</title>

    Twenty Eleven already tries to add a relevant title tag. The WordPress SEO plugin is probably then adding the duplicate part. For a quick test, you could disable that plugin and see if it clears it up. If the plugin is the culprit, try poking at any of its relevant settings.

  4. danielfontaine176
    Member
    Posted 2 years ago #

    Thanks Bagel. I did deactivate and it removed the doubles.

    I still haven't found in WordPress SEO where to modify but at least I know it is in there somewhere.

    I really appreciated the advice and reply.

    Thank you!

  5. danielfontaine176
    Member
    Posted 2 years ago #

    I have look around and can't find where in WordPress SEO to deactivate this setting. Anyone else using WordPress SEO know where I can disable it?

  6. It's a bug in the Twenty Eleven/WordPress SEO combination.

    Per Yoast:

    The issue is that the title tag in Twenty Eleven is absolutely horrible in the way it's implemented. I'm currently working with several core contributors on a patch to entirely change the way WordPress handles titles, so all of this would no longer be needed, at least for up to date themes.

  7. danielfontaine176
    Member
    Posted 2 years ago #

    thank you for the reply. I don't want to disable it so I will deal with the double page titles for now.

  8. cameldance
    Member
    Posted 2 years ago #

    I was just having this issue earlier today running the WordPress SEO plugin with the Twenty Eleven theme. What took care of it for me was changing the long, bloated default <title> tag in header.php to simply be <title><?php wp_title(''); ?></title>

  9. danielfontaine176
    Member
    Posted 2 years ago #

    thanks cameldance. I just tried that and it looks like it worked. Thank you!

  10. cameldance
    Member
    Posted 2 years ago #

    Cool, I'm glad that worked!

  11. cleanteam
    Member
    Posted 2 years ago #

    thanks cameldance, that was solving mine too. Let me reward you with the most beautiful camel I've ever met. http://www.youtube.com/watch?v=VSYTaICXJnY

  12. cavcopy
    Member
    Posted 2 years ago #

    Solved mine too!

Topic Closed

This topic has been closed to new replies.

About this Topic