WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Double Border on Posts (7 posts)

  1. cms2043
    Member
    Posted 1 year ago #

    Hello,
    My site is http://www.thepaisleybox.com. Here is a copy of my code:
    http://pastebin.com/PHQi5uUx

    The problem I am having is that all my posts on the homepage (except for the first post) have two borders, which is throwing off the alignment. I want all posts to look like the very first post.
    Can someone help determine why this is?

    Thank You,
    Colleen

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    The problem seems to be with all posts subsequent to the first are inside the first post.

    Also try validating your website against W3C's validator.

  3. cms2043
    Member
    Posted 1 year ago #

    Correct. When I click on an individual post or category, the problem also goes away.

    I tried the validator but there seem to be a lot of errors and unfortunately I'm not sure what they mean.
    If you can give me an idea of what I'm looking for in those errors, I'll try to correct them, but there are about 50 so I can't do every one...

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    This webpage contains explanations of all errors generating by the validator
    http://validator.w3.org/docs/errors.html

  5. cms2043
    Member
    Posted 1 year ago #

    Sorry, 29 errors...I exaggerated a bit.
    Either way, I'm not sure what I am looking for.

    Do you think it's a problem with the <div class="more_entries"> section of the template because it's not happening to the first post?

  6. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    http://codex.wordpress.org/Validating_a_Website

    the error is possibly just in the content of the latest post -
    you can check that, when you click on the title to view the single post, you get the sidebar dropped to the bottom.

    edit the post 'Perfect Pairings: Wedding Version' using the html setting of the editor, and look for

    <div style="padding-top:10px;">

    either remove that or add a corresponding </div> to the end of the content.

  7. cms2043
    Member
    Posted 1 year ago #

    Yes!!! Thank you so much. That did the trick.

    I always add that code (<div style="padding-top:10px;">) after my images to give a bit of space between image and text. This was the first time I added it to the end of the post...I guess I can't do that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags