WordPress.org

Ready to get started?Download WordPress

Forums

Youtube Channel Gallery
[resolved] Dots appearing between Thumbnail and title (4 posts)

  1. jorisk322
    Member
    Posted 1 year ago #

    Hello. I have a problem with your plugin. I installed it and added this shortcode to my page:
    [Youtube_Channel_Gallery feed="playlist" user="PLmGLbWfde7xmoezVCZ7KXyzl16SN8etdg" videowidth="580" ratio="16x9" theme="light" color="white" autoplay="0" rel="1" showinfo="1" maxitems="9" thumbwidth="183" thumbratio="16x9" thumbcolumns="3" title="1" description="1" thumbnail_alignment="top" descriptionwordsnumber="10"]
    That works, but there are dots between the thumbnails and the videos. I saw in the demo that this isn't supposed to look this way.

    Thanks in advance!

    (http://islandsofmadness.com/?page_id=427 is the page with the problem)

    http://wordpress.org/extend/plugins/youtube-channel-gallery/

  2. poudro
    Member
    Posted 1 year ago #

    One of the content filters is injecting a rogue openning <p> without closeing it anywhere. I don't know which one though.

    If you only have one post with the gallery, a quick fix for this would be :

    function remove_extra_p($content)
    {
      global $post;
    
      if ($post->ID == YOUR_POST_ID)
        return preg_replace('/<p>/','',$content);
    
      return $content;
    }
    add_filter( 'the_content', 'remove_extra_p', 200 );
  3. jorisk322
    Member
    Posted 1 year ago #

    @poudro, thanks, but where would I add this? Also, I'm not sure if it matters, but it's not in a post. It's on a page.

  4. jefmcclimans
    Member
    Posted 11 months ago #

    @jorisk322 How did you resolve this issue? I am having a similar problem, but it is adding the dot above the title of the widget?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic