WordPress.org

Ready to get started?Download WordPress

Forums

Media Grid
[resolved] Don't work (11 posts)

  1. Li-An
    Member
    Posted 10 months ago #

  2. shaunandrews
    Member
    Plugin Author

    Posted 10 months ago #

    This is likely a browser issue. Can you tell me what browser (including OS and version) you're using?

  3. Li-An
    Member
    Posted 10 months ago #

    Firefox -last version - windows seven 32 bits family.

  4. Li-An
    Member
    Posted 10 months ago #

    You are right, it works on webkit motor (Maxthon 4).

  5. shaunandrews
    Member
    Plugin Author

    Posted 10 months ago #

    I'm guessing flexbox is the likely culprit. I'll do some testing and see what I can do. I may have to revert back to using floated boxes, and lose the coolness of the flexbox layout. :(

  6. I'm running FF 24 and getting the same thing.

    Definitely seems to be related to Firefox not fully supporting flex-wrap or similar.

    I'm guessing flexbox is the likely culprit. I'll do some testing and see what I can do. I may have to revert back to using floated boxes, and lose the coolness of the flexbox layout.

    Why not use the bundled Masonry library or is that still semi-janky in responsive layouts?

  7. chenz2
    Member
    Posted 10 months ago #

    I get same error in firefox.

  8. shaunandrews
    Member
    Plugin Author

    Posted 10 months ago #

    I haven't had a chance to try masonry as a solution. I'll try to find some time to work on this and get a fix out the door ASAP. Thanks for trying the plugin.

  9. shaunandrews
    Member
    Plugin Author

    Posted 10 months ago #

    Version 0.4 of the plugin should resolve this layout issue. Let me know if you run into any other troubles. Thanks!

  10. Li-An
    Member
    Posted 10 months ago #

    It works now in Firefox. Thanks for the fix.

  11. pronkman
    Member
    Posted 10 months ago #

    Last update also fixed issue with Firefox on Mac. Thx! One small suggestion... The media thumbnail and options bar overlaps by about 10px – fixed it by removing the top and bottom position of .media-thumb img. I don't know if this has any implications for Window users but on Mac it now works perfect.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.