WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Don't want lines showing in table (12 posts)

  1. jillibilli
    Member
    Posted 5 years ago #

    No matter what I do, I get a grey line around each cell in my table. I want the lines to be invisible.

    This is the html code on the page:

    <table style="border-style: solid; border-width: 0pt;" border="0" cellspacing="0" cellpadding="0" width="100%" frame="none" align="center">

    No color, width, or border is specified. What am I doing wrong?

  2. Kim Parsell
    Volunteer Moderator
    Posted 5 years ago #

    Try changing it to:

    <table style="border: none; border-collapse: collapse;" border="0" cellspacing="0" cellpadding="0" width="100%" align="center">

  3. jillibilli
    Member
    Posted 5 years ago #

    Thanks for the response, but, sorry, that didn't work. Still see the grey lines.

  4. Kim Parsell
    Volunteer Moderator
    Posted 5 years ago #

    Can you provide a link to the page containing the table?

  5. jillibilli
    Member
    Posted 5 years ago #

  6. Evita
    Member
    Posted 5 years ago #

    What am I doing wrong?

    Maybe looking in your style.css?

    #content table
    {
    	margin-bottom: 15px;
    	border-collapse: collapse;
    	font-size: 1em;
    	border: solid 1px #ccc;
    }
    #content table tr th
    {
    	padding: 5px 5px;
    	font-weight: bold;
    	text-align: center;
    	background-color: #f0f0f0;
    	border: solid 1px #ccc;
    }
    #content table tr td
    {
    	padding: 5px 5px;
    	border: solid 1px #ccc;
    }
  7. jillibilli
    Member
    Posted 5 years ago #

    Evita,

    My style.css looks exactly like the one you sent. Maybe I need to change the border: settings? If so, what to I change them to? Do I change the "solid 1px #ccc" settings?

    Thanks!!!

  8. jillibilli
    Member
    Posted 5 years ago #

    Anyone still looking into this for me? I'm at a loss!

  9. Kim Parsell
    Volunteer Moderator
    Posted 5 years ago #

    Change border: solid 1px #ccc; to border: solid 0px #ccc; in each of the above-listed item from your stylesheet, one at a time, and testing each time until the border disappears in the section you want it removed from.

  10. jillibilli
    Member
    Posted 5 years ago #

    Thanks! Changing the border to 0px worked but now all of the tables in my site are messed up.

    Here's the scoop:

    **My home page is http://hamc.org. That's the only page I don't want the table borders showing.

    **On my other pages (examples: http://hamc.org/about-us/board-of-trustees/ and http://hamc.org/school-life/bekesher/) I want all of the table borders to show but only the outside ones are visible.

    **I went to the table properties for those individual tables and changed the settings to the following: <table style="border: #cccccc 1px solid;" border="1" cellspacing="1" cellpadding="5" width="100%"> to no avail.

    This is so confusing!!!

  11. jillibilli
    Member
    Posted 5 years ago #

    I figured it out! I need to add a border color to the cell properties and then apply it to all the cells in the table. When you do the table properties, it only adds the color to the outside border!

    Thanks to both of you for your help. It was invaluable.

  12. dvogno
    Member
    Posted 4 years ago #

    This worked for me to create a table without borders.

    <table style="border:1px solid #ffffff ;" border="0" cellspacing="0" cellpadding="0" width="400">
    <tr>
    <td style="border:1px solid #ffffff ">
    Table Content Here
    </td>
    </tr>
    </table>

Topic Closed

This topic has been closed to new replies.

About this Topic