WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Don't upgrade to 0.9.2.10 (16 posts)

1 star
  1. benweston2002
    Member
    Posted 1 year ago #

    My site runs on the latest version of WordPress on a dedicated CentOS server running Apache and PHP through FastCGI. The previous version of W3TC was brilliant and did a fantastic job of minifying and caching through Opcode APC caching. Since upgrading, NOTHING works. I get a constant "Minify Auto encountered an error. The filename length value is most likely too high for your host. It is currently 150. The plugin is trying to solve the issue for you: (solving ...)" error every time I enable minifying and, even when I switch to manual mode and configure it all that way, NOTHING is minified. I have tried APC and disk caching methods and have played around with the filename length values to no avail. I am now forced to use an alternative, inferior minify and caching plugin because W3TC simply will not work anymore.

  2. zappmania
    Member
    Posted 1 year ago #

    Hi I am also facing the same issue
    I am on windows hosting.
    http://www.zappmania.in

  3. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    May I have an opportunity to fix bugs before receiving a poor review? Will you please submit a bug submission form from the support tab of the plugin so that I can learn more about your environment(s)?

  4. zappmania
    Member
    Posted 1 year ago #

    Sure Frederick

    Site link is http://www.zappmania.in

    Plugin Version: 0.9.2.10
    PHP Version: 5.2.17;
    Web Server: Microsoft IIS
    FTP functions: Installed (required for Self-hosted (FTP) CDN support)
    Multibyte String support: Installed (required for Rackspace Cloud Files support)
    cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
    zlib extension: Installed (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    HTML Tidy extension: Not installed (required for HTML Tidy minifier suppport)
    Mime type detection: Not installed (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA / MaxCDN CDN purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    set_time_limit: Available
    Additional modules

    New Relic
    PHP version: Supported
    Operating System: Not Supported. Windows NT BJJI-GLOBEDNS 5.2 build 3790 See NewRelic requirements page.
    Web Server: Not Supported. Microsoft-IIS/6.0 See NewRelic requirements page.

    Fancy permalinks: /%year%/%monthnum%/%day%/%postname%/
    WP_CACHE define: Defined (true)
    URL rewrite: Disabled
    Network mode: No

  5. benweston2002
    Member
    Posted 1 year ago #

    Hi Frederick Townes. I have already submitted a very detailed bug report with as much info as possible but heard nothing back. I'm not unfair - I'm happy to alter my review accordingly if/when the bug is fixed but, right now, for me it is a 1 star plugin now as it doesn't work... at all!

  6. Tarun Bansal
    Member
    Posted 1 year ago #

    I am also facing same problem in new version but if you check properly you will find that the minify functionality is working properly. It is just showing that error message in admin panel whenever you change any settings related to minify.

    Hope Frederick Townes solves the issue soon and post any patch for solving the problem in version 0.9.2.10 if possible.

  7. benweston2002
    Member
    Posted 1 year ago #

    Nope, neither Minify nor combine worked at all for me - even when I set it up manually and included the scripts I wanted minified. Am now using WP Minify and Super Cache plugins and the site is actually faster with fewer HTTP requests than when using W3TC before!

  8. rstaveley
    Member
    Posted 1 year ago #

    +1 here. Can't avoid the

    Minify Auto does not work properly. Try using Minify Manual instead or try another Minify cache method. You can also try a lower filename length value manually
    error with 0.9.2.10.

  9. Hari P V
    Member
    Posted 1 year ago #

    i'm also facing the same issue, i'm using hostgator shared server.after plugin activation showing one plugin drop in showing in wordpress dashboard. error screenshot attached

    http://prntscr.com/15nx1p

    http://prntscr.com/15ny82

  10. onydchic
    Member
    Posted 1 year ago #

    I just installed this for the first time, completely broke my design with the above error. And I seem to have lost most of the settings for some reason.

  11. attikdrum
    Member
    Posted 1 year ago #

    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /home/content/85/9832385/html/wp-content/db.php.

    http://www.entre-chums.com ..... can't find a solution. I don't have my username/password of my http://FTP.. using FileZilla and doesn't work.

  12. @attikdrum: Stop spamming old threads with your problem!

    I don't have my username/password for http://FTP....

    Ask your webhost for the info.

  13. Sperry77
    Member
    Posted 1 year ago #

    Sadly, I had to remove W3 Total Cache. It was working wonderfully except for a minor issue re iPad caching. But then, minify gave an error - and it tried to solve the error but couldn't. I couldn't log into WP anymore and my site was down. Had to delete all files via FTP (which was a real pain the arse!). So now... I'm considering Super Cache and WP Minify. Sad, cause I really liked W3 Total Cache. But I can't go through hours of finding and deleting files in case the minify error happens again upon reinstall. Error was something about file or filename being too large.

  14. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Some of the minify issues relating to the test should be resolved with .11. Upcomming release will have more fixes. The auto test is due to various hosts support different filename lengths. Some minor issues getting it to work properly across the board.

    @benweston2002 If you are still having issues with Minify manual not working could you send a bug report with wp login and ftp so we can take a look at the issue you are having?

  15. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    @zappmania, theres been changes to the htaccess rules that are generated for Minify. Have you verified that the ones used with IIS match the ones that are visible on the install page of the plugin with regards to Minify?

  16. zappmania
    Member
    Posted 11 months ago #

    new vresion is running like a charm.
    thanks
    http://www.zappmania.in

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic