WordPress.org

Ready to get started?Download WordPress

Forums

Two Factor Auth
[resolved] Don't see "Click to enter one time password" button on my local (8 posts)

  1. tccarter
    Member
    Posted 11 months ago #

    Hello,

    I'm excited to try your plugin but thought that before I installed it on the site that I have on my development server I would install in locally so that I could get it into version control. After installing your plugin (and initially hooking it into Google Authenticator and when that didn't work tried it with default functionality which failed too) I would log out and give it a shot. When I went to the login screen I saw the default WordPress login missing the button to add my one time password. I saw that someone reported a conflict with GA so I removed that folder to see if it got your plugin working as expected but no luck. I checked the settings as well and it looks Any suggestions?

    Thank you,

    TCC

    http://wordpress.org/plugins/two-factor-auth/

  2. oskarhane
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    Sorry for the delay of this reply.
    Yes, I never got the other guy to answer me again and I couldn't get the same error as he.

    What do you mean with "hooking into Google Authenticator failed"?
    Is the WP installation on Windows or Linux?
    What version of WP do you use?

    Could you somehow send me a link to the login page so I can check it out? I know you have it locally but can you expose that to the internet for a short while?

    Thanks for the report,
    /Oskar

  3. tccarter
    Member
    Posted 11 months ago #

    Hello,

    I was trying to get this working locally on my Mac using MAMP which it occurs to me might not be something that will work. I can't give you a login without having you ssh into my machine.

    I should say that I first tried to use to plugin by using a third party app "Google Authenticator" which didn't seem to work where upon I tried it with the default "email" option and that didn't give me an option to click the "one time password" button which did not appear.

    I can try installing the plugin on my dev server if it's not going to work with MAMP, I'm just in the habit of using my local development environment before my remote. So before I go about giving you passwords I should verify that it won't work on my remote server first, yes? Let me see if that works and get back to you.

    Thank you,

    TCC

  4. tccarter
    Member
    Posted 11 months ago #

    Also, I'm using wordpress 3.5.2 for now.

    The remote dev I'm working with is running on Linux.

  5. tccarter
    Member
    Posted 11 months ago #

    I was unable to get the plugin to work on my remote development site even after deactivating all other plugins so I'm stuck.

    Can I send you the login link off line so that I'm not pasting it in a forum for all to see?

  6. oskarhane
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks for all the info!
    Please, send the link to oh at oskarhane.com so I can take a look at it.

  7. oskarhane
    Member
    Plugin Author

    Posted 11 months ago #

    After a lot of testing with great help from @tccarter we found out that the theme used [WP-Foundation](http://320press.com/wp-foundation/) did an ugly thing and loaded an empty jQuery script that breaks all plugins that uses jQuery on the login page.

    Here's a working version that can be used for these situations: http://cl.ly/041D0R1D2D3q

    [I filed a bug to WordPress](http://core.trac.wordpress.org/ticket/25017) and hopefully they won't allow registration of empty scripts in the future, but some (rightfully) see this as an feature.

    We'll see what happens.

  8. oskarhane
    Member
    Plugin Author

    Posted 9 months ago #

    This issue is fixed in 3.7 which will be coming out soon!

    http://core.trac.wordpress.org/ticket/25017

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.