WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Don't automatically make images clickable (8 posts)

  1. ingejanse
    Member
    Posted 4 years ago #

    Since WordPress 2.9 (I think), the default setting after uploading an image via WordPress is to automatically add a link to the source (see for instance the image on the top left on http://www.eclectro.nl/2010-01-10-julien-dyne-van-down-under-naar-grote-hoogte from my website). I want the default setting after uploading to be that no link is added, and that the image is just displayed. How can this default setting be changed?

  2. Jacob N. Breetvelt
    Member
    Posted 4 years ago #

    Mag het in het nederlands?

    Heel simpel:
    Bij het uploaden kan je uit drie knoppen kiezen bij 'Koppelings-url',
    namelijk: 'Geen', 'Bestands-.. 'en 'Bericht..'.

    Kies 'Geen' en het is zoals je het wil.

    Noot: De laatste keuze wordt onthouden, dus opletten de volgende keer.

    Als je een bestaande wil veranderen kan je in de HTML stand van de editor ook het stukje <a href=....> en </a> slopen zodat alleen het stuk <img ......." /> overblijft.

    Succes!

  3. ingejanse
    Member
    Posted 4 years ago #

    @ opajaap: thank you for your comment. I'm aware of the option to choose 'none' for image linking (after uploading), but this option is not remembered by WordPress. Hence, each time I upload a new image, the default setting is that it links to itself in the post. I want WordPress to remember that the image link should be put on 'none' by default. Anyone any clue how to do this?

  4. Jacob N. Breetvelt
    Member
    Posted 4 years ago #

    That is strange, mine remembers the last setting.

    Are you running 2.9.1 ?

  5. ingejanse
    Member
    Posted 4 years ago #

    Yup, 2.9.1 is there. I remember that this always worked like you described (choose 'none' once, and it is remembered), but that this isn't the case anymore since (I think) 2.9.

    Bonus question: how is this setting remembered? Is it stored in the database for my wp profile, or is it stored in a cookie or something local alike?

  6. Jacob N. Breetvelt
    Member
    Posted 4 years ago #

    Yep! found it in a cookie.

    Cookie name: wp-settings-2

    It is a very long cookie, but somewhere it says 'urlbutton post' or
    (after changing the way described earlier) 'urlbutton none' or 'urlbutton file'
    This cookie also 'remembers' your last choices of alignment and size.

    So if you run ccleaner often, uncheck clean cookies for the browser you use, and use the same browser everytime, or be aware of this.

    Thank you for your suggestion, it was in the right direction.
    Case closed?

    Regards

  7. Jacob N. Breetvelt
    Member
    Posted 4 years ago #

    If this is not enough, take a look at
    this post
    Looks like your problem. A solution is to go to the media settings panel and simply save the changes.

    Solution by 'lionc'

    Regards again

  8. ingejanse
    Member
    Posted 4 years ago #

    Oh, gorgeous! I did the media save trick, and now the default behaviour is no link at all. I'll have to see if the trick keeps working in the future, but for now it seems very promising. Thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Topic