WordPress.org

Ready to get started?Download WordPress

Forums

Done, but with errors on page. (3 posts)

  1. anthonygreen2
    Member
    Posted 5 years ago #

    Hi guys,

    My blog is up and running, I like it a lot - just need to add regular content now.

    One thing that is an annoyance, is that when I view my website, I get the message 'Done, but with errors on page' at the bottom left of my browser.

    I ran this: http://validator.w3.org/check?uri=http%3A%2F%2Fclassicsimplicityofegg.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0&st=1&user-agent=W3C_Validator%2F1.654

    It would appear I have a lot of errors!! How do I go about fixing this? do the errors relate to a php file, if so, which one?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Done, but with errors on page

    If you're using IE, this message indicates that one of your page's javascript files has 1 or more errors in it. That's quite a separate issues to validation issues.

    And, yes, you do have rather a lot of errors (215 to be exact). A lot of them seem to relate to javascript(s) within your page. If they're within the theme template files, then they need to be moved out of the page and into external scripts. Otherwise, the javascript could be added by plugins.

    The page also shows instances of old, invalid markup (uppercase instead of lowercase) and deprecated attributes/tags such as font, 'align', 'center' etc.

    If you're creating post/page content in an HTML editor and then pasting that into WordPress, stop. Your HTML editor is old and outdated. Create your content in WordPress itself.

    If these errors are coming from your theme rather than your content, and you have created or customised the theme, you need to go back into your template files and correct your markup. If you haven't customised this theme and you don't have the technical skills to do so, then you need to change themes and/or look for some up-to-date plugins.

  3. Alpha1one
    Member
    Posted 4 years ago #

    I have a error on my blog with the icon at the bottom left page or post. When I click on the page I get
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SearchToolbar 1.1; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
    Timestamp: Fri, 25 Jun 2010 01:56:36 UTC

    Message: 'document.getElementById(...)' is null or not an object
    Line: 3
    Char: 2
    Code: 0
    URI: http://jamsource.net/beautifulboldcurves/wp-content/themes/inuit-types/library/js/suckerfish.js

    Whats in blod is the visible error. I also cant add links to my pages or post when i click on the link it gives me an 404 error. Please he;p and resolve this problem as soon as possible.

Topic Closed

This topic has been closed to new replies.

About this Topic