WordPress.org

Ready to get started?Download WordPress

Forums

Donate Plus - Paypal issue. (5 posts)

  1. Jue
    Member
    Posted 2 years ago #

    I've been getting this email:

    Dear Julian Vass,

    Please check your server that handles PayPal Instant Payment Notifications (IPN). Instant Payment Notifications sent to the following URL(s) are failing:

    http://magpiewatch.co.uk/wp-content/plugins/donate-plus/paypal.php

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.

    Thank you for your prompt attention to this issue.

    Yours sincerely,

    PayPal

    Any ideas?

  2. megasipp
    Member
    Posted 2 years ago #

    I am having the same problem and get the same exact email.

    Under the settings for Donate Plus it says "This is your IPN Notification URL. If you have issues with your site receiving your PayPal payments, be sure to manually set this URL in your PayPal Profile IPN settings." (above this it gives your IPN Notification URL). I tried to add this to Paypal but it said it wasn't a proper URL or something. I'm not sure what to do.....

  3. jimbeach
    Member
    Posted 2 years ago #

    Below is what I got from my web hosting support and it worked for me. Read all of it and you will find the fix is in the paypal.php file, near the top: change 'testing-mode' to 'live-mode'. For some reason this is not being changed through your settings in the admin screen.

    After you make this change it may take a couple of days for all of your unsent IPN messages to be sent. You can check their status by logging into PayPal, select "History" from the menu, select "IPN History" from the drop-down. View the list of messages and their status. Some will have a status of "retrying". Those that have been successful will have a status of "sent".

    "Regarding the 404 error specifically, this seems to be by design, as the following bit of code shows:
    # Check for IPN post if non then return 404 error.
    if (!$_POST['txn_type']){
    if( $email_IPN_results ) send_mail($send_mail_to,$sysname." [ERROR - 404]","IPN Fail: 404 error!","",__LINE__);
    header("Status: 404 Not Found");
    die();
    }else{
    header("Status: 200 OK");
    }
    ----
    Now that we know Paypal is encountering the same 404 error that I encounter when I attempt to visit http://www.whateveryourdomainis.com/wp-content/plugins/donate-plus/paypal.php via a command line, I suspect the issue is isolated to the settings within the paypal.php file not being setup properly to coincide with what Paypal is sending, or vice versa. It may be entirely isolated to the "$verifymode = $dplus['testing_mode'];" setting within this file, needing to be set to "live_mode"."

  4. etstow
    Member
    Posted 1 year ago #

    Here's how I fixed it...

    In the donate-plus.php file there are two instances of something like this...
    str_replace(ABSPATH, trailingslashit(get_option('siteurl')), dirname(__FILE__)).'/paypal.php'

    Replace the first so it looks something like this...
    <?php _e('http://www.WEBSITE.COM/wp-content/plugins/donate-plus/paypal.php','dplus');?>

    The second should be...
    $notify = 'http://www.WEBSITE.COM/wp-content/plugins/donate-plus/paypal.php';

    Hope that helps!

  5. nickharambee
    Member
    Posted 1 year ago #

    I am experiencing the same issue, with every entry in my IPN showing "Retrying" with the 404 error. I have made the changes suggested by jimbeach and etstow, but it doesn't fix the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic